blob: 4904a8e0f052b05c7f8e3337a0f48c0af069b5b2 [file] [log] [blame]
Andrew Geissler84ad7c52020-06-27 00:00:16 -05001SUMMARY = "Building and installing bootgen"
2DESCRIPTION = "Building and installing bootgen, a Xilinx tool that lets you stitch binary files together and generate device boot images"
3
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=be5410bcde8eb6481a6e5d3b22e0740b"
6
7S = "${WORKDIR}/git"
8
9DEPENDS += "openssl"
10RDEPENDS_${PN} += "openssl"
11
12REPO ?= "git://github.com/Xilinx/bootgen.git;protocol=https"
13BRANCH ?= "master"
14SRCREV ?= "bb38995468d8c830cbbfc5062e903961444c0a3c"
15
16BRANCHARG = "${@['nobranch=1', 'branch=${BRANCH}'][d.getVar('BRANCH', True) != '']}"
17SRC_URI = "${REPO};${BRANCHARG}"
18
19EXTRA_OEMAKE += 'CROSS_COMPILER="${CXX}" -C ${S}'
20CXXFLAGS_append = " -std=c++0x"
21
22TARGET_CC_ARCH += "${LDFLAGS}"
23
24do_install() {
25 install -d ${D}${bindir}
26 install -Dm 0755 ${S}/bootgen ${D}${bindir}
27}
28
29FILES_${PN} = "${bindir}/bootgen"
30
31BBCLASSEXTEND = "native nativesdk"