Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 1 | SUMMARY = "Ultra fast JSON encoder and decoder for Python" |
| 2 | DESCRIPTION = "UltraJSON is an ultra fast JSON encoder and decoder written in pure C with bindings for Python 2.5+ and 3." |
| 3 | |
| 4 | LICENSE = "BSD-3-Clause" |
| 5 | LIC_FILES_CHKSUM = "file://PKG-INFO;beginline=8;endline=8;md5=88df8e78b9edfd744953862179f2d14e" |
| 6 | |
| 7 | SRC_URI[md5sum] = "42f77b0cce686dfa4da2e68480b1dd24" |
| 8 | SRC_URI[sha256sum] = "f66073e5506e91d204ab0c614a148d5aa938bdbf104751be66f8ad7a222f5f86" |
| 9 | |
| 10 | inherit pypi ptest setuptools3 |
| 11 | |
| 12 | SRC_URI += " \ |
| 13 | file://run-ptest \ |
| 14 | " |
| 15 | |
| 16 | RDEPENDS_${PN} += "\ |
| 17 | ${PYTHON_PN}-datetime \ |
| 18 | ${PYTHON_PN}-numbers \ |
| 19 | " |
| 20 | |
| 21 | RDEPENDS_${PN}-ptest += " \ |
| 22 | ${PYTHON_PN}-pytz \ |
| 23 | " |
| 24 | |
| 25 | do_install_ptest() { |
| 26 | install -d ${D}${PTEST_PATH}/tests |
| 27 | cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/ |
| 28 | } |
| 29 | |
| 30 | BBCLASSEXTEND = "native nativesdk" |