Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 1 | SUMMARY = "Console mouse driver" |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 2 | DESCRIPTION = "GPM (General Purpose Mouse) is a mouse server \ |
| 3 | for the console and xterm, with sample clients included \ |
| 4 | (emacs, etc)." |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 5 | HOMEPAGE = "https://www.nico.schottelius.org/software/gpm" |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 6 | SECTION = "console/utils" |
| 7 | LICENSE = "GPLv2+" |
| 8 | LIC_FILES_CHKSUM = "file://COPYING;md5=18810669f13b87348459e611d31ab760" |
| 9 | |
| 10 | PV = "1.99.7+git${SRCREV}" |
| 11 | PR = "r2" |
| 12 | SRCREV = "1fd19417b8a4dd9945347e98dfa97e4cfd798d77" |
| 13 | |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 14 | DEPENDS = "ncurses bison-native" |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 15 | |
| 16 | SRC_URI = "git://github.com/telmich/gpm;protocol=git \ |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 17 | file://init \ |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 18 | file://gpm.service.in \ |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 19 | file://0001-Use-sigemptyset-API-instead-of-__sigemptyset.patch \ |
| 20 | " |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 21 | |
| 22 | S = "${WORKDIR}/git" |
| 23 | |
| 24 | inherit autotools-brokensep update-rc.d systemd |
| 25 | |
| 26 | INITSCRIPT_NAME = "gpm" |
| 27 | INITSCRIPT_PARAMS = "defaults" |
| 28 | |
| 29 | do_configure_prepend() { |
| 30 | (cd ${S};./autogen.sh;cd -) |
| 31 | } |
| 32 | |
| 33 | do_install_append () { |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 34 | install -d ${D}${systemd_system_unitdir} |
| 35 | sed 's:@bindir@:${sbindir}:' < ${WORKDIR}/gpm.service.in >${D}${systemd_system_unitdir}/gpm.service |
| 36 | install -D -m 0755 ${WORKDIR}/init ${D}${INIT_D_DIR}/gpm |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 37 | ln -s libgpm.so.2 ${D}${libdir}/libgpm.so |
| 38 | } |
| 39 | |
| 40 | SYSTEMD_SERVICE_${PN} = "gpm.service" |