Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 1 | SUMMARY = "ACPICA tools for the development and debug of ACPI tables" |
| 2 | DESCRIPTION = "The ACPI Component Architecture (ACPICA) project provides an \ |
| 3 | OS-independent reference implementation of the Advanced Configuration and \ |
| 4 | Power Interface Specification (ACPI). ACPICA code contains those portions of \ |
| 5 | ACPI meant to be directly integrated into the host OS as a kernel-resident \ |
| 6 | subsystem, and a small set of tools to assist in developing and debugging \ |
| 7 | ACPI tables." |
| 8 | |
| 9 | HOMEPAGE = "http://www.acpica.org/" |
| 10 | SECTION = "console/tools" |
| 11 | |
Brad Bishop | 1d80a2e | 2019-11-15 16:35:03 -0500 | [diff] [blame] | 12 | LICENSE = "Intel | BSD | GPLv2" |
| 13 | LIC_FILES_CHKSUM = "file://source/compiler/aslcompile.c;beginline=7;endline=150;md5=b5690d9ef8d54b2b1e1cc98aad64cd87" |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 14 | |
| 15 | COMPATIBLE_HOST = "(i.86|x86_64|arm|aarch64).*-linux" |
| 16 | |
| 17 | DEPENDS = "bison flex bison-native" |
| 18 | |
Brad Bishop | 1d80a2e | 2019-11-15 16:35:03 -0500 | [diff] [blame] | 19 | SRC_URI = "https://acpica.org/sites/acpica/files/acpica-unix-${PV}.tar.gz" |
| 20 | SRC_URI[md5sum] = "539a0252bcb42c383ceeaeb12ae9a60d" |
| 21 | SRC_URI[sha256sum] = "029db4014600e4b771b11a84276d2d76eb40fb26eabc85864852ef1f962be95f" |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 22 | UPSTREAM_CHECK_URI = "https://acpica.org/downloads" |
| 23 | |
Brad Bishop | 1d80a2e | 2019-11-15 16:35:03 -0500 | [diff] [blame] | 24 | S = "${WORKDIR}/acpica-unix-${PV}" |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 25 | |
| 26 | inherit update-alternatives |
| 27 | |
| 28 | ALTERNATIVE_PRIORITY = "100" |
| 29 | ALTERNATIVE_${PN} = "acpixtract acpidump" |
| 30 | |
| 31 | EXTRA_OEMAKE = "CC='${CC}' \ |
| 32 | OPT_CFLAGS=-Wall \ |
| 33 | DESTDIR=${D} \ |
| 34 | PREFIX=${prefix} \ |
| 35 | INSTALLDIR=${bindir} \ |
| 36 | INSTALLFLAGS= \ |
| 37 | " |
| 38 | |
| 39 | do_install() { |
| 40 | oe_runmake install |
| 41 | } |
| 42 | |
| 43 | # iasl*.bb is a subset of this recipe, so RREPLACE it |
| 44 | PROVIDES = "iasl" |
| 45 | RPROVIDES_${PN} += "iasl" |
| 46 | RREPLACES_${PN} += "iasl" |
| 47 | RCONFLICTS_${PN} += "iasl" |
| 48 | |
| 49 | BBCLASSEXTEND = "native" |