Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 1 | SUMMARY = "C++ framework for json-rpc 1.0 and 2.0" |
| 2 | DESCRIPTION = "JsonRpc-Cpp is an OpenSource implementation of JSON-RPC \ |
| 3 | protocol in C++. JSON-RPC is a lightweight remote procedure \ |
| 4 | call protocol similar to XML-RPC." |
| 5 | HOMEPAGE = "https://github.com/cinemast/libjson-rpc-cpp" |
| 6 | LICENSE = "MIT" |
| 7 | LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=4e728c5b36018f6c383b4b9efd9c8840" |
| 8 | SECTION = "libs" |
| 9 | |
| 10 | DEPENDS = "curl jsoncpp libmicrohttpd hiredis" |
| 11 | |
Andrew Geissler | 6aa7eec | 2023-03-03 12:41:14 -0600 | [diff] [blame] | 12 | SRC_URI = "git://github.com/cinemast/libjson-rpc-cpp;branch=master;protocol=https" |
Andrew Geissler | bffdb3e | 2020-08-21 16:13:29 -0500 | [diff] [blame] | 13 | |
Andrew Geissler | 6aa7eec | 2023-03-03 12:41:14 -0600 | [diff] [blame] | 14 | SRCREV = "ec5ce12fc9c0299e1454cc002c70218b5a6f005b" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 15 | |
| 16 | S = "${WORKDIR}/git" |
| 17 | |
| 18 | PACKAGECONFIG ?= "" |
| 19 | PACKAGECONFIG[coverage] = "-DWITH_COVERAGE=YES,-DWITH_COVERAGE=NO,," |
| 20 | |
| 21 | inherit cmake |
| 22 | |
| 23 | EXTRA_OECMAKE += "-DCOMPILE_TESTS=NO -DCOMPILE_STUBGEN=NO -DCOMPILE_EXAMPLES=NO \ |
| 24 | -DBUILD_SHARED_LIBS=YES -DBUILD_STATIC_LIBS=YES \ |
| 25 | -DCMAKE_LIBRARY_PATH=${libdir} \ |
| 26 | " |
| 27 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 28 | FILES:${PN}-dev += "${libdir}/libjson-rpc-cpp/cmake" |