blob: 73701ec72e10302116998efd7f9871c1097b5b15 [file] [log] [blame]
Patrick Williams92b42cb2022-09-03 06:53:57 -05001SUMMARY = "Dominate is a Python library for creating and manipulating HTML documents using an elegant DOM API."
2LICENSE = "LGPL-3.0-only"
3LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=b52f2d57d10c4f7ee67a7eb9615d5d24"
4
Patrick Williamse760df82023-05-26 11:10:49 -05005SRC_URI[sha256sum] = "4c90c3befaf88e612b71f4b39af7bcbef8977acfa855cec957225a8fbf504007"
Patrick Williams92b42cb2022-09-03 06:53:57 -05006
7inherit pypi setuptools3 ptest
8
9SRC_URI += " \
10 file://run-ptest \
11"
12
13RDEPENDS:${PN}-ptest += " \
14 ${PYTHON_PN}-pytest \
15"
16
17do_install_ptest() {
18 install -d ${D}${PTEST_PATH}/tests
19 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
20}
21
22RDEPENDS:${PN} += "\
23 ${PYTHON_PN}-numbers \
24 ${PYTHON_PN}-threading \
25 "