Patrick Williams | 92b42cb | 2022-09-03 06:53:57 -0500 | [diff] [blame] | 1 | SUMMARY = "A microframework based on Werkzeug, Jinja2 and good intentions" |
| 2 | DESCRIPTION = "\ |
| 3 | Flask is a microframework for Python based on Werkzeug, Jinja 2 and good \ |
| 4 | intentions. And before you ask: It’s BSD licensed!" |
| 5 | HOMEPAGE = "https://github.com/mitsuhiko/flask/" |
| 6 | LICENSE = "BSD-3-Clause" |
| 7 | LIC_FILES_CHKSUM = "file://LICENSE.rst;md5=ffeffa59c90c9c4a033c7574f8f3fb75" |
| 8 | |
Patrick Williams | 2a25492 | 2023-08-11 09:48:11 -0500 | [diff] [blame] | 9 | SRC_URI[sha256sum] = "8c2f9abd47a9e8df7f0c3f091ce9497d011dc3b31effcf4c85a6e2b50f4114ef" |
Patrick Williams | 92b42cb | 2022-09-03 06:53:57 -0500 | [diff] [blame] | 10 | |
| 11 | PYPI_PACKAGE = "Flask" |
| 12 | |
Patrick Williams | 2a25492 | 2023-08-11 09:48:11 -0500 | [diff] [blame] | 13 | inherit pypi python_setuptools_build_meta |
Patrick Williams | 92b42cb | 2022-09-03 06:53:57 -0500 | [diff] [blame] | 14 | |
| 15 | CLEANBROKEN = "1" |
| 16 | |
| 17 | RDEPENDS:${PN} = " \ |
Patrick Williams | 2a25492 | 2023-08-11 09:48:11 -0500 | [diff] [blame] | 18 | ${PYTHON_PN}-blinker \ |
Patrick Williams | 92b42cb | 2022-09-03 06:53:57 -0500 | [diff] [blame] | 19 | ${PYTHON_PN}-click \ |
Patrick Williams | 2a25492 | 2023-08-11 09:48:11 -0500 | [diff] [blame] | 20 | ${PYTHON_PN}-itsdangerous \ |
| 21 | ${PYTHON_PN}-jinja2 \ |
Patrick Williams | 92b42cb | 2022-09-03 06:53:57 -0500 | [diff] [blame] | 22 | ${PYTHON_PN}-profile \ |
Patrick Williams | 2a25492 | 2023-08-11 09:48:11 -0500 | [diff] [blame] | 23 | ${PYTHON_PN}-werkzeug \ |
Patrick Williams | 92b42cb | 2022-09-03 06:53:57 -0500 | [diff] [blame] | 24 | " |