blob: 834bb031ca48a5cd3c122c537cb799278b181fa9 [file] [log] [blame]
Andrew Geissler9aee5002022-03-30 16:27:02 +00001SUMMARY = "Provides both a high- and low-level interface to the HDF5 library from Python."
2HOMEPAGE = "https://www.h5py.org/"
3SECTION = "devel/python"
4LICENSE = "BSD-3-Clause"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=113251d71fb0384712c719b567261c5c"
6
Andrew Geissler8f840682023-07-21 09:09:43 -05007SRC_URI[sha256sum] = "e604db6521c1e367c6bd7fad239c847f53cc46646f2d2651372d05ae5e95f817"
Andrew Geissler9aee5002022-03-30 16:27:02 +00008
Andrew Geisslerfc113ea2023-03-31 09:59:46 -05009SRC_URI += "file://0001-setup_build.py-avoid-absolute-path.patch"
Andrew Geissler9aee5002022-03-30 16:27:02 +000010
11inherit pkgconfig pypi setuptools3
12
13BBCLASSEXTEND = "native"
14
15DEPENDS = "python3-pkgconfig-native \
16 python3-cython-native \
17 python3-numpy-native \
18 python3-six-native \
19 hdf5-native \
20 python3 \
21 hdf5 \
22 "
23
Patrick Williams8e7b46e2023-05-01 14:19:06 -050024PACKAGESPLITFUNCS =+ "fix_cythonized_sources"
25
26fix_cythonized_sources() {
27 for f in `grep -l -r -e '\/* Generated by Cython.*/$' ${PKGD}/usr/src/debug/${PN}/${EXTENDPE}${PV}-${PR}`; do
28 if [ -e $f ]; then
29 sed -i -e 's#${RECIPE_SYSROOT_NATIVE}##g' $f
30 fi
31 done
32}
33
Andrew Geissler9aee5002022-03-30 16:27:02 +000034RDEPENDS:${PN} = "python3-numpy \
35 python3-six \
36 python3-json \
37 "
38
Andrew Geisslerfc113ea2023-03-31 09:59:46 -050039export HDF5_VERSION="1.14.0"