blob: af5009b6ae2f7a7fa101d03651c5ec3d8aeaf6e5 [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SUMMARY = "Tornado is an open source version of the scalable, non-blocking web server and tools that power FriendFeed."
2DESCRIPTION = "Tornado is a Python web framework and asynchronous networking library, originally developed at FriendFeed. \
3By using non-blocking network I/O, Tornado can scale to tens of thousands of open connections, making it ideal for long \
4polling, WebSockets, and other applications that require a long-lived connection to each user."
5HOMEPAGE = "http://www.tornadoweb.org/en/stable/"
6LICENSE = "Apache-2.0"
Andrew Geissler4b7c1152020-11-30 19:55:29 -06007LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
Patrick Williamsb48b7b42016-08-17 15:04:38 -05008
Patrick Williams8e7b46e2023-05-01 14:19:06 -05009SRC_URI[sha256sum] = "d68f3192936ff2c4add04dc21a436a43b4408d466746b78bb2b9d0a53a18683f"
Patrick Williamsb48b7b42016-08-17 15:04:38 -050010
Andrew Geissler89770b02020-06-13 10:40:47 -050011inherit pypi setuptools3
12
13# Requires _compression which is currently located in misc
Patrick Williamsb542dec2023-06-09 01:26:37 -050014RDEPENDS:${PN} += " \
15 python3-asyncio \
16 python3-certifi \
17 python3-compression \
18 python3-ctypes \
19 python3-email \
20 python3-html \
21 python3-json \
22 python3-misc \
23 python3-multiprocessing \
24 python3-numbers \
25 python3-pkgutil \
26 python3-pycurl \
27 python3-threading \
28 python3-unittest \
29"
Patrick Williamsb48b7b42016-08-17 15:04:38 -050030
Patrick Williamsb542dec2023-06-09 01:26:37 -050031RDEPENDS:${PN}-test += "python3-unittest"
Patrick Williamsb48b7b42016-08-17 15:04:38 -050032
33PACKAGES =+ "\
34 ${PN}-test \
35"
36
Patrick Williams213cb262021-08-07 19:21:33 -050037FILES:${PN}-test = " \
Patrick Williamsb48b7b42016-08-17 15:04:38 -050038 ${libdir}/${PYTHON_DIR}/site-packages/*/test \
Patrick Williamsb48b7b42016-08-17 15:04:38 -050039"