Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 1 | SUMMARY = "Tornado is an open source version of the scalable, non-blocking web server and tools that power FriendFeed." |
| 2 | DESCRIPTION = "Tornado is a Python web framework and asynchronous networking library, originally developed at FriendFeed. \ |
| 3 | By using non-blocking network I/O, Tornado can scale to tens of thousands of open connections, making it ideal for long \ |
| 4 | polling, WebSockets, and other applications that require a long-lived connection to each user." |
| 5 | HOMEPAGE = "http://www.tornadoweb.org/en/stable/" |
| 6 | LICENSE = "Apache-2.0" |
Andrew Geissler | 4b7c115 | 2020-11-30 19:55:29 -0600 | [diff] [blame] | 7 | LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57" |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 8 | |
Patrick Williams | 8e7b46e | 2023-05-01 14:19:06 -0500 | [diff] [blame] | 9 | SRC_URI[sha256sum] = "d68f3192936ff2c4add04dc21a436a43b4408d466746b78bb2b9d0a53a18683f" |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 10 | |
Andrew Geissler | 89770b0 | 2020-06-13 10:40:47 -0500 | [diff] [blame] | 11 | inherit pypi setuptools3 |
| 12 | |
| 13 | # Requires _compression which is currently located in misc |
Patrick Williams | b542dec | 2023-06-09 01:26:37 -0500 | [diff] [blame] | 14 | RDEPENDS:${PN} += " \ |
| 15 | python3-asyncio \ |
| 16 | python3-certifi \ |
| 17 | python3-compression \ |
| 18 | python3-ctypes \ |
| 19 | python3-email \ |
| 20 | python3-html \ |
| 21 | python3-json \ |
| 22 | python3-misc \ |
| 23 | python3-multiprocessing \ |
| 24 | python3-numbers \ |
| 25 | python3-pkgutil \ |
| 26 | python3-pycurl \ |
| 27 | python3-threading \ |
| 28 | python3-unittest \ |
| 29 | " |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 30 | |
Patrick Williams | b542dec | 2023-06-09 01:26:37 -0500 | [diff] [blame] | 31 | RDEPENDS:${PN}-test += "python3-unittest" |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 32 | |
| 33 | PACKAGES =+ "\ |
| 34 | ${PN}-test \ |
| 35 | " |
| 36 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 37 | FILES:${PN}-test = " \ |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 38 | ${libdir}/${PYTHON_DIR}/site-packages/*/test \ |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 39 | " |