Andrew Geissler | 3eeda90 | 2023-05-19 10:14:02 -0500 | [diff] [blame] | 1 | SUMMARY = "A pure-python library for embedding CoSWID data" |
| 2 | HOMEPAGE = "https://github.com/hughsie/python-uswid" |
| 3 | SECTION = "devel/python" |
| 4 | LICENSE = "LGPL-2.1-or-later" |
| 5 | |
| 6 | DEPENDS += " python3-cbor2 python3-lxml python3-pefile" |
Patrick Williams | b542dec | 2023-06-09 01:26:37 -0500 | [diff] [blame] | 7 | RDEPENDS:${PN} += " \ |
| 8 | python3-cbor2 \ |
| 9 | python3-json \ |
| 10 | python3-lxml \ |
| 11 | python3-netclient \ |
| 12 | " |
Andrew Geissler | 3eeda90 | 2023-05-19 10:14:02 -0500 | [diff] [blame] | 13 | LIC_FILES_CHKSUM = "file://LICENSE;md5=40d2542b8c43a3ec2b7f5da31a697b88" |
| 14 | |
| 15 | SRC_URI = "git://github.com/hughsie/python-uswid.git;branch=main;protocol=https" |
| 16 | SRCREV = "3223034abef88ae29cf79fdc7fe11ec7e21e11ff" |
| 17 | S = "${WORKDIR}/git" |
| 18 | |
| 19 | inherit setuptools3 python3native |
| 20 | |
| 21 | BBCLASSEXTEND = "native nativesdk" |