Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 1 | SUMMARY = "Perl module that run many filetest checks on a tree" |
| 2 | DESCRIPTION = "The validate() routine takes a single multiline string consisting \ |
| 3 | of directives, each containing a filename plus a file test to try on it. (The file \ |
| 4 | test may also be a "cd", causing subsequent relative filenames to be interpreted \ |
| 5 | relative to that directory.) After the file test you may put || die to make it a \ |
| 6 | fatal error if the file test fails. The default is || warn. The file test may \ |
| 7 | optionally have a "!' prepended to test for the opposite condition. If you do a \ |
| 8 | cd and then list some relative filenames, you may want to indent them slightly for \ |
| 9 | readability. If you supply your own die() or warn() message, you can use $file to \ |
| 10 | interpolate the filename. \ |
| 11 | \ |
| 12 | Filetests may be bunched: "-rwx" tests for all of -r, -w, and -x. Only the first failed \ |
| 13 | test of the bunch will produce a warning. \ |
| 14 | \ |
| 15 | The routine returns the number of warnings issued." |
| 16 | |
| 17 | HOMEPAGE = "http://search.cpan.org/~flora/File-CheckTree/" |
| 18 | SECTION = "libs" |
| 19 | LICENSE = "Artistic-1.0 | GPL-1.0+" |
| 20 | |
| 21 | LIC_FILES_CHKSUM = "file://LICENSE;md5=c6fcacc5df80e037060300a7f4b93bf9" |
| 22 | |
| 23 | SRC_URI = "http://search.cpan.org/CPAN/authors/id/F/FL/FLORA/File-CheckTree-${PV}.tar.gz" |
| 24 | |
| 25 | SRC_URI[md5sum] = "519c82aa7e5b7f752b4da14a6c8ad740" |
| 26 | SRC_URI[sha256sum] = "fc99ab6bb5af4664832715974b5a19e328071dc9202ab72e5d5a594ebd46a729" |
| 27 | |
| 28 | S = "${WORKDIR}/File-CheckTree-${PV}" |
| 29 | |
| 30 | inherit cpan |
| 31 | |
| 32 | BBCLASSEXTEND = "native" |