Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 1 | SUMMARY = "Command line tool and library for client-side URL transfers" |
| 2 | HOMEPAGE = "http://curl.haxx.se/" |
| 3 | BUGTRACKER = "http://curl.haxx.se/mail/list.cgi?list=curl-tracker" |
| 4 | SECTION = "console/network" |
| 5 | LICENSE = "MIT" |
| 6 | LIC_FILES_CHKSUM = "file://COPYING;beginline=7;md5=3a34942f4ae3fbf1a303160714e664ac" |
| 7 | |
| 8 | SRC_URI = "http://curl.haxx.se/download/curl-${PV}.tar.bz2 \ |
| 9 | file://pkgconfig_fix.patch \ |
| 10 | " |
| 11 | |
| 12 | # curl likes to set -g0 in CFLAGS, so we stop it |
| 13 | # from mucking around with debug options |
| 14 | # |
Patrick Williams | f1e5d69 | 2016-03-30 15:21:19 -0500 | [diff] [blame] | 15 | SRC_URI += " file://configure_ac.patch \ |
| 16 | file://CVE-2016-0754.patch \ |
| 17 | file://CVE-2016-0755.patch" |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 18 | |
| 19 | SRC_URI[md5sum] = "6b952ca00e5473b16a11f05f06aa8dae" |
| 20 | SRC_URI[sha256sum] = "1e2541bae6582bb697c0fbae49e1d3e6fad5d05d5aa80dbd6f072e0a44341814" |
| 21 | |
| 22 | inherit autotools pkgconfig binconfig multilib_header |
| 23 | |
| 24 | PACKAGECONFIG ??= "${@bb.utils.contains("DISTRO_FEATURES", "ipv6", "ipv6", "", d)} gnutls zlib" |
| 25 | PACKAGECONFIG_class-native = "ipv6 ssl zlib" |
| 26 | PACKAGECONFIG_class-nativesdk = "ipv6 ssl zlib" |
| 27 | |
| 28 | PACKAGECONFIG[ipv6] = "--enable-ipv6,--disable-ipv6," |
| 29 | PACKAGECONFIG[ssl] = "--with-ssl --with-random=/dev/urandom,--without-ssl,openssl" |
| 30 | PACKAGECONFIG[gnutls] = "--with-gnutls,--without-gnutls,gnutls" |
| 31 | PACKAGECONFIG[zlib] = "--with-zlib=${STAGING_LIBDIR}/../,--without-zlib,zlib" |
| 32 | PACKAGECONFIG[rtmpdump] = "--with-librtmp,--without-librtmp,rtmpdump" |
| 33 | PACKAGECONFIG[libssh2] = "--with-libssh2,--without-libssh2,libssh2" |
| 34 | PACKAGECONFIG[smb] = "--enable-smb,--disable-smb," |
| 35 | |
| 36 | EXTRA_OECONF = "--without-libidn \ |
| 37 | --enable-crypto-auth \ |
| 38 | --disable-ldap \ |
| 39 | --disable-ldaps \ |
| 40 | --with-ca-bundle=${sysconfdir}/ssl/certs/ca-certificates.crt \ |
| 41 | " |
| 42 | # see https://lists.yoctoproject.org/pipermail/poky/2013-December/009435.html |
| 43 | # We should ideally drop ac_cv_sizeof_off_t from site files but until then |
| 44 | EXTRA_OECONF += "${@bb.utils.contains('DISTRO_FEATURES', 'largefile', 'ac_cv_sizeof_off_t=8', '', d)}" |
| 45 | |
| 46 | do_install_append() { |
| 47 | oe_multilib_header curl/curlbuild.h |
| 48 | } |
| 49 | |
Patrick Williams | f1e5d69 | 2016-03-30 15:21:19 -0500 | [diff] [blame] | 50 | do_install_append_class-target() { |
| 51 | # cleanup buildpaths from curl-config |
| 52 | sed -i -e 's,${STAGING_DIR_HOST},,g' ${D}${bindir}/curl-config |
| 53 | } |
| 54 | |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 55 | PACKAGES =+ "lib${BPN}" |
| 56 | |
| 57 | FILES_lib${BPN} = "${libdir}/lib*.so.*" |
| 58 | RRECOMMENDS_lib${BPN} += "ca-certificates" |
| 59 | |
| 60 | BBCLASSEXTEND = "native nativesdk" |