Brad Bishop | a34c030 | 2019-09-23 22:34:48 -0400 | [diff] [blame] | 1 | From 3f3e7b16934ec58ab47d2bdc9982f54a55b07534 Mon Sep 17 00:00:00 2001 |
| 2 | From: Hongxu Jia <hongxu.jia@windriver.com> |
| 3 | Date: Wed, 21 Aug 2019 16:25:33 +0800 |
| 4 | Subject: [PATCH] fix compile failure with debian patches |
| 5 | |
| 6 | While applying debian patches, there is a compile failure |
| 7 | ... |
| 8 | elfutils-0.177/backends/mips_init.c:48:5: error: 'Ebl' {aka 'struct ebl'} has no member named 'name' |
| 9 | ... |
| 10 | |
| 11 | Since upstream applied commit [b323391 libdwelf: Add dwelf_elf_e_machine_string |
| 12 | and use it in readelf], it remove 'name' from 'struct ebl' |
| 13 | |
| 14 | Upstream-Status: Pending |
| 15 | |
| 16 | Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com> |
| 17 | --- |
| 18 | backends/mips_init.c | 1 - |
| 19 | backends/parisc_init.c | 1 - |
| 20 | 2 files changed, 2 deletions(-) |
| 21 | |
| 22 | diff --git a/backends/mips_init.c b/backends/mips_init.c |
| 23 | index bce5abe..e1c65c8 100644 |
| 24 | --- a/backends/mips_init.c |
| 25 | +++ b/backends/mips_init.c |
| 26 | @@ -45,7 +45,6 @@ mips_init (Elf *elf __attribute__ ((unused)), |
| 27 | return NULL; |
| 28 | |
| 29 | /* We handle it. */ |
| 30 | - eh->name = "MIPS"; |
| 31 | mips_init_reloc (eh); |
| 32 | HOOK (eh, reloc_simple_type); |
| 33 | HOOK (eh, return_value_location); |
| 34 | diff --git a/backends/parisc_init.c b/backends/parisc_init.c |
| 35 | index f1e401c..97b4a8c 100644 |
| 36 | --- a/backends/parisc_init.c |
| 37 | +++ b/backends/parisc_init.c |
| 38 | @@ -56,7 +56,6 @@ parisc_init (Elf *elf __attribute__ ((unused)), |
| 39 | pa64 = 1; |
| 40 | } |
| 41 | /* We handle it. */ |
| 42 | - eh->name = "PA-RISC"; |
| 43 | parisc_init_reloc (eh); |
| 44 | HOOK (eh, reloc_simple_type); |
| 45 | HOOK (eh, machine_flag_check); |
| 46 | -- |
| 47 | 2.7.4 |
| 48 | |