blob: a1acfcd00503340e051c864213e060bd38b348ed [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001SUMMARY = "display dialog boxes from shell scripts"
2DESCRIPTION = "Dialog lets you to present a variety of questions \
3or display messages using dialog boxes from a shell \
4script (or any scripting language)."
5HOMEPAGE = "http://invisible-island.net/dialog/"
6SECTION = "console/utils"
7DEPENDS = "ncurses"
8LICENSE = "LGPL-2.1"
9LIC_FILES_CHKSUM = "file://COPYING;md5=a6f89e2100d9b6cdffcea4f398e37343"
10
11SRC_URI = "ftp://ftp.invisible-island.net/${BPN}/${BP}.tgz \
12 "
Brad Bishop2f973922019-11-11 07:58:48 -050013SRC_URI[md5sum] = "f48b597251a26c522002736652e0300c"
14SRC_URI[sha256sum] = "886e12f2cf3df36cde65f32f6ae52bc598eb2599a611b1d8ce5dfdea599e47e2"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080015
16# hardcoded here for use in dialog-static recipe
17S = "${WORKDIR}/dialog-${PV}"
18
19inherit autotools-brokensep pkgconfig
20
21EXTRA_OECONF = "--with-ncurses \
22 --disable-rpath-hack"
23
24do_configure() {
25 gnu-configize --force
26 sed -i 's,${cf_ncuconfig_root}6-config,${cf_ncuconfig_root}-config,g' -i configure
27 sed -i 's,cf_have_ncuconfig=unknown,cf_have_ncuconfig=yes,g' -i configure
28 oe_runconf
29}