Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 1 | SUMMARY = "display dialog boxes from shell scripts" |
| 2 | DESCRIPTION = "Dialog lets you to present a variety of questions \ |
| 3 | or display messages using dialog boxes from a shell \ |
| 4 | script (or any scripting language)." |
| 5 | HOMEPAGE = "http://invisible-island.net/dialog/" |
| 6 | SECTION = "console/utils" |
| 7 | DEPENDS = "ncurses" |
| 8 | LICENSE = "LGPL-2.1" |
| 9 | LIC_FILES_CHKSUM = "file://COPYING;md5=a6f89e2100d9b6cdffcea4f398e37343" |
| 10 | |
| 11 | SRC_URI = "ftp://ftp.invisible-island.net/${BPN}/${BP}.tgz \ |
| 12 | " |
Brad Bishop | 2f97392 | 2019-11-11 07:58:48 -0500 | [diff] [blame] | 13 | SRC_URI[md5sum] = "f48b597251a26c522002736652e0300c" |
| 14 | SRC_URI[sha256sum] = "886e12f2cf3df36cde65f32f6ae52bc598eb2599a611b1d8ce5dfdea599e47e2" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 15 | |
| 16 | # hardcoded here for use in dialog-static recipe |
| 17 | S = "${WORKDIR}/dialog-${PV}" |
| 18 | |
| 19 | inherit autotools-brokensep pkgconfig |
| 20 | |
| 21 | EXTRA_OECONF = "--with-ncurses \ |
| 22 | --disable-rpath-hack" |
| 23 | |
| 24 | do_configure() { |
| 25 | gnu-configize --force |
| 26 | sed -i 's,${cf_ncuconfig_root}6-config,${cf_ncuconfig_root}-config,g' -i configure |
| 27 | sed -i 's,cf_have_ncuconfig=unknown,cf_have_ncuconfig=yes,g' -i configure |
| 28 | oe_runconf |
| 29 | } |