blob: 9c9ae94fcfd76ba42b53992ac619e4729152479a [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001SUMMARY = "Backup, restore, import, and export panel layouts"
2SECTION = "x11/application"
3LICENSE = "GPLv3"
4LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
5
Brad Bishop8410d612019-11-25 09:40:59 -05006inherit python3native gettext features_check
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08007
8REQUIRED_DISTRO_FEATURES = "x11"
9
10DEPENDS += "intltool-native"
11
Brad Bishope42b3e32020-01-15 22:08:42 -050012SRC_URI = "http://archive.xfce.org/src/apps/${BPN}/1.0/${BP}.tar.bz2"
13SRC_URI[md5sum] = "bee3e251e45ade0ea349366461d6e200"
14SRC_URI[sha256sum] = "a8c00af838e85d00600dbf442c8741aa21a332fbceba849e0820560630a6e0ce"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080015
16do_configure() {
17 # special configure - no autotools...
18 ./configure --prefix=${prefix}
19}
20
21do_install() {
22 oe_runmake 'DESTDIR=${D}' install
23 sed -i 's:${PYTHON}:python3:g' ${D}${bindir}/xfce4-panel-profiles
24}
25
26FILES_${PN} += "${datadir}/metainfo"
27
28RDEPENDS_${PN} += "python3-pygobject python3-pexpect"