Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 1 | SUMMARY = "Backup, restore, import, and export panel layouts" |
| 2 | SECTION = "x11/application" |
| 3 | LICENSE = "GPLv3" |
| 4 | LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504" |
| 5 | |
Brad Bishop | 8410d61 | 2019-11-25 09:40:59 -0500 | [diff] [blame] | 6 | inherit python3native gettext features_check |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 7 | |
| 8 | REQUIRED_DISTRO_FEATURES = "x11" |
| 9 | |
| 10 | DEPENDS += "intltool-native" |
| 11 | |
Brad Bishop | e42b3e3 | 2020-01-15 22:08:42 -0500 | [diff] [blame] | 12 | SRC_URI = "http://archive.xfce.org/src/apps/${BPN}/1.0/${BP}.tar.bz2" |
| 13 | SRC_URI[md5sum] = "bee3e251e45ade0ea349366461d6e200" |
| 14 | SRC_URI[sha256sum] = "a8c00af838e85d00600dbf442c8741aa21a332fbceba849e0820560630a6e0ce" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 15 | |
| 16 | do_configure() { |
| 17 | # special configure - no autotools... |
| 18 | ./configure --prefix=${prefix} |
| 19 | } |
| 20 | |
| 21 | do_install() { |
| 22 | oe_runmake 'DESTDIR=${D}' install |
| 23 | sed -i 's:${PYTHON}:python3:g' ${D}${bindir}/xfce4-panel-profiles |
| 24 | } |
| 25 | |
| 26 | FILES_${PN} += "${datadir}/metainfo" |
| 27 | |
| 28 | RDEPENDS_${PN} += "python3-pygobject python3-pexpect" |