William A. Kennington III | e33ec59 | 2021-03-10 17:43:48 -0800 | [diff] [blame] | 1 | SUMMARY = "Allows hooking netlink events to perform network actions" |
| 2 | PR = "r1" |
| 3 | LICENSE = "Apache-2.0" |
| 4 | LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10" |
| 5 | |
| 6 | inherit systemd |
| 7 | |
| 8 | SRC_URI += " \ |
| 9 | file://gbmc-ip-monitor.service \ |
| 10 | file://gbmc-ip-monitor.sh \ |
| 11 | file://gbmc-ip-monitor-test.sh \ |
| 12 | " |
| 13 | |
| 14 | S = "${WORKDIR}" |
| 15 | |
| 16 | DEPENDS += "test-sh" |
| 17 | |
| 18 | RDEPENDS_${PN} += " \ |
| 19 | bash \ |
| 20 | iproute2 \ |
| 21 | " |
| 22 | |
| 23 | SYSTEMD_SERVICE_${PN} += "gbmc-ip-monitor.service" |
| 24 | |
| 25 | do_compile() { |
| 26 | SYSROOT="$PKG_CONFIG_SYSROOT_DIR" bash gbmc-ip-monitor-test.sh || exit |
| 27 | } |
| 28 | |
| 29 | do_install_append() { |
| 30 | install -d -m0755 ${D}${libexecdir} |
| 31 | install -m0755 gbmc-ip-monitor.sh ${D}${libexecdir}/ |
| 32 | |
| 33 | install -d -m0755 ${D}${systemd_system_unitdir} |
| 34 | install -m0644 gbmc-ip-monitor.service ${D}${systemd_system_unitdir}/ |
| 35 | } |