Ben Pai | a8c7bfc | 2020-03-31 16:34:40 +0800 | [diff] [blame] | 1 | SUMMARY = "Wistron OEM commands" |
| 2 | DESCRIPTION = "Wistron OEM commands" |
| 3 | HOMEPAGE = "https://github.com/openbmc/wistron-ipmi-oem" |
| 4 | PR = "r1" |
| 5 | PV = "0.1+git${SRCPV}" |
| 6 | LICENSE = "Apache-2.0" |
| 7 | LIC_FILES_CHKSUM = "file://LICENSE;md5=fa818a259cbed7ce8bc2a22d35a464fc" |
| 8 | |
| 9 | inherit autotools pkgconfig |
| 10 | inherit obmc-phosphor-ipmiprovider-symlink |
| 11 | |
| 12 | DEPENDS += "phosphor-ipmi-host" |
| 13 | DEPENDS += "autoconf-archive-native" |
| 14 | |
| 15 | S = "${WORKDIR}/git" |
| 16 | SRC_URI = "git://github.com/openbmc/wistron-ipmi-oem" |
Andrew Geissler | af6439f | 2020-11-11 03:10:53 +0000 | [diff] [blame] | 17 | SRCREV = "ba89a1ea570cb010c2e929ac11ada3714878ca7d" |
Ben Pai | a8c7bfc | 2020-03-31 16:34:40 +0800 | [diff] [blame] | 18 | |
| 19 | FILES_${PN}_append = " ${libdir}/ipmid-providers/lib*${SOLIBS}" |
| 20 | FILES_${PN}_append = " ${libdir}/host-ipmid/lib*${SOLIBS}" |
| 21 | FILES_${PN}-dev_append = " ${libdir}/ipmid-providers/lib*${SOLIBSDEV} ${libdir}/ipmid-providers/*.la" |
| 22 | |
| 23 | HOSTIPMI_PROVIDER_LIBRARY += "libwistronoem.so" |