blob: d3abc611be1dbcc947ad30ba09de001df6b37579 [file] [log] [blame]
Andrew Geissler84ad7c52020-06-27 00:00:16 -05001COMPATIBLE_HOST = "${HOST_SYS}"
2
3# Add MicroBlaze Patches (only when using MicroBlaze)
Andrew Geissler10fa1492020-12-11 16:25:29 -06004FILESEXTRAPATHS_append_microblaze_xilinx-standalone := ":${THISDIR}/gcc-10"
Andrew Geissler84ad7c52020-06-27 00:00:16 -05005SRC_URI_append_microblaze_xilinx-standalone = " \
6 file://additional-microblaze-multilibs.patch \
7"
Andrew Geissleraaf90cd2021-02-12 15:29:51 -06008
9CHECK_FOR_MICROBLAZE_microblaze = "1"
10
11python() {
12 if d.getVar('CHECK_FOR_MICROBLAZE') == '1':
13 if 'xilinx-microblaze' not in d.getVar('BBFILE_COLLECTIONS').split():
14 bb.fatal('You must include the meta-microblaze layer to build for this configuration.')
15}