Andrew Geissler | 84ad7c5 | 2020-06-27 00:00:16 -0500 | [diff] [blame] | 1 | COMPATIBLE_HOST = "${HOST_SYS}" |
| 2 | |
| 3 | # Add MicroBlaze Patches (only when using MicroBlaze) |
Andrew Geissler | 10fa149 | 2020-12-11 16:25:29 -0600 | [diff] [blame] | 4 | FILESEXTRAPATHS_append_microblaze_xilinx-standalone := ":${THISDIR}/gcc-10" |
Andrew Geissler | 84ad7c5 | 2020-06-27 00:00:16 -0500 | [diff] [blame] | 5 | SRC_URI_append_microblaze_xilinx-standalone = " \ |
| 6 | file://additional-microblaze-multilibs.patch \ |
| 7 | " |
Andrew Geissler | aaf90cd | 2021-02-12 15:29:51 -0600 | [diff] [blame] | 8 | |
| 9 | CHECK_FOR_MICROBLAZE_microblaze = "1" |
| 10 | |
| 11 | python() { |
| 12 | if d.getVar('CHECK_FOR_MICROBLAZE') == '1': |
| 13 | if 'xilinx-microblaze' not in d.getVar('BBFILE_COLLECTIONS').split(): |
| 14 | bb.fatal('You must include the meta-microblaze layer to build for this configuration.') |
| 15 | } |