Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 1 | SUMMARY = "Generic font configuration library" |
| 2 | DESCRIPTION = "Fontconfig is a font configuration and customization library, which \ |
| 3 | does not depend on the X Window System. It is designed to locate \ |
| 4 | fonts within the system and select them according to requirements \ |
| 5 | specified by applications. \ |
| 6 | Fontconfig is not a rasterization library, nor does it impose a \ |
| 7 | particular rasterization library on the application. The X-specific \ |
| 8 | library 'Xft' uses fontconfig along with freetype to specify and \ |
| 9 | rasterize fonts." |
| 10 | |
| 11 | HOMEPAGE = "http://www.fontconfig.org" |
| 12 | BUGTRACKER = "https://bugs.freedesktop.org/enter_bug.cgi?product=fontconfig" |
| 13 | |
| 14 | LICENSE = "MIT-style & MIT & PD" |
| 15 | LIC_FILES_CHKSUM = "file://COPYING;md5=7a0449e9bc5370402a94c00204beca3d \ |
| 16 | file://src/fcfreetype.c;endline=45;md5=5d9513e3196a1fbfdfa94051c09dfc84 \ |
| 17 | file://src/fccache.c;beginline=1367;endline=1382;md5=0326cfeb4a7333dd4dd25fbbc4b9f27f" |
| 18 | |
| 19 | SECTION = "libs" |
| 20 | |
| 21 | DEPENDS = "expat freetype zlib gperf-native" |
| 22 | |
| 23 | SRC_URI = "http://fontconfig.org/release/fontconfig-${PV}.tar.gz \ |
| 24 | file://revert-static-pkgconfig.patch \ |
| 25 | file://0001-src-fcxml.c-avoid-double-free-of-filename.patch \ |
| 26 | " |
| 27 | |
| 28 | SRC_URI[md5sum] = "00e748c67fad11e7057a71ed385e8bdb" |
| 29 | SRC_URI[sha256sum] = "064b9ebf060c9e77011733ac9dc0e2ce92870b574cca2405e11f5353a683c334" |
| 30 | |
| 31 | UPSTREAM_CHECK_REGEX = "fontconfig-(?P<pver>\d+\.\d+\.(?!9\d+)\d+)" |
| 32 | |
| 33 | do_configure_prepend() { |
| 34 | # work around https://bugs.freedesktop.org/show_bug.cgi?id=101280 |
| 35 | rm -f ${S}/src/fcobjshash.h ${S}/src/fcobjshash.gperf |
| 36 | } |
| 37 | |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 38 | do_install_append_class-target() { |
| 39 | # duplicate fc-cache for postinstall script |
| 40 | mkdir -p ${D}${libexecdir} |
| 41 | ln ${D}${bindir}/fc-cache ${D}${libexecdir}/${MLPREFIX}fc-cache |
| 42 | } |
| 43 | |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 44 | PACKAGES =+ "fontconfig-utils" |
| 45 | FILES_${PN} =+ "${datadir}/xml/*" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 46 | FILES_fontconfig-utils = "${bindir}/* ${libexecdir}/*" |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 47 | |
| 48 | # Work around past breakage in debian.bbclass |
| 49 | RPROVIDES_fontconfig-utils = "libfontconfig-utils" |
| 50 | RREPLACES_fontconfig-utils = "libfontconfig-utils" |
| 51 | RCONFLICTS_fontconfig-utils = "libfontconfig-utils" |
| 52 | DEBIAN_NOAUTONAME_fontconfig-utils = "1" |
| 53 | |
| 54 | inherit autotools pkgconfig relative_symlinks |
| 55 | |
| 56 | FONTCONFIG_CACHE_DIR ?= "${localstatedir}/cache/fontconfig" |
| 57 | |
| 58 | # comma separated list of additional directories |
| 59 | # /usr/share/fonts is already included by default (you can change it with --with-default-fonts) |
| 60 | FONTCONFIG_FONT_DIRS ?= "no" |
| 61 | |
| 62 | EXTRA_OECONF = " --disable-docs --with-default-fonts=${datadir}/fonts --with-cache-dir=${FONTCONFIG_CACHE_DIR} --with-add-fonts=${FONTCONFIG_FONT_DIRS}" |
| 63 | |
| 64 | BBCLASSEXTEND = "native" |