Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 1 | SUMMARY = "A library for using PKCS" |
| 2 | DESCRIPTION = "pkcs11-helper is a library that simplifies the interaction with PKCS \ |
| 3 | providers for end-user applications using a simple API and optional OpenSSL \ |
| 4 | engine. The library allows using multiple PKCS enumerating available token \ |
| 5 | certificates, or selecting a certificate directly by serialized id, handling \ |
| 6 | card removal and card insert events, handling card ie-insert to a different \ |
| 7 | slot, supporting session expiration and much more all using a simple API." |
| 8 | |
| 9 | HOMEPAGE = "http://www.opensc-project.org/pkcs11-helper/" |
| 10 | SECTION = "Development/Libraries" |
| 11 | |
| 12 | LICENSE = "GPLv2 & BSD" |
| 13 | LIC_FILES_CHKSUM = " \ |
| 14 | file://COPYING;md5=4948810631bcac142af53d32df5b6ee1 \ |
| 15 | file://COPYING.GPL;md5=8a71d0475d08eee76d8b6d0c6dbec543 \ |
| 16 | file://COPYING.BSD;md5=f79f90ea7a106796af80b5d05f1f8da1 \ |
| 17 | " |
| 18 | SRC_URI = "git://github.com/OpenSC/${BPN}.git" |
| 19 | SRC_URI[md5sum] = "9f62af9f475901b89355266141306673" |
| 20 | SRC_URI[sha256sum] = "494ec59c93e7c56c528f335d9353849e2e7c94a6b1b41c89604694e738113386" |
| 21 | |
| 22 | S = "${WORKDIR}/git" |
| 23 | SRCREV = "e7adf8f35be232a4f04c53b4ac409be52792093e" |
| 24 | |
| 25 | DEPENDS = "zlib nettle gnutls gmp openssl nss nspr" |
| 26 | |
| 27 | inherit autotools pkgconfig |
| 28 | |
| 29 | EXTRA_OECONF = "--disable-static" |