Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 1 | DESCRIPTION = "The gflags package contains a C++ library that implements commandline flags processing. It includes built-in support for standard types such as string and the ability to define flags in the source file in which they are used" |
| 2 | |
| 3 | HOMEPAGE = "https://github.com/gflags/gflags" |
| 4 | |
| 5 | LICENSE = "BSD-3-Clause" |
| 6 | LIC_FILES_CHKSUM = "file://COPYING.txt;md5=c80d1a3b623f72bb85a4c75b556551df" |
| 7 | |
| 8 | SRC_URI = "git://github.com/gflags/gflags.git" |
| 9 | SRCREV = "f8a0efe03aa69b3336d8e228b37d4ccb17324b88" |
| 10 | |
| 11 | S = "${WORKDIR}/git" |
| 12 | |
| 13 | FILES_${PN}-dev += "${libdir}/cmake" |
| 14 | |
| 15 | inherit cmake |
| 16 | |
| 17 | EXTRA_OECMAKE="-DBUILD_SHARED_LIBS=ON -DREGISTER_INSTALL_PREFIX=OFF -DLIB_INSTALL_DIR=${baselib}" |
| 18 | |
| 19 | PACKAGES =+ "${PN}-bash-completion" |
| 20 | FILES_${PN}-bash-completion += "${bindir}/gflags_completions.sh" |
| 21 | RDEPENDS_${PN}-bash-completion = "bash bash-completion" |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 22 | |
| 23 | BBCLASSEXTEND = "native" |