blob: 3e18ad71e5290050a5c377848ad0782ba7684d58 [file] [log] [blame]
Thang Q. Nguyen72eb1512021-02-06 01:22:45 +00001SUMMARY = "Ampere Computing LLC Update MAC Address from FRU Inventory Information"
2DESCRIPTION = "Update MAC Address from FRU Inventory Information for Ampere systems"
3PR = "r1"
4
5LICENSE = "Apache-2.0"
6
7LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
8
9inherit systemd
10inherit obmc-phosphor-systemd
11
12DEPENDS = "systemd"
13RDEPENDS_${PN} = "bash"
14
15FILESEXTRAPATHS_append := "${THISDIR}/${PN}:"
16
17SRC_URI += " \
18 file://ampere_update_mac.sh \
19 "
20
21SYSTEMD_SERVICE_${PN} = "ampere_update_mac.service"
22
23do_install_append() {
24 install -d ${D}/${sbindir}
25 install -m 755 ${WORKDIR}/ampere_update_mac.sh ${D}/${sbindir}
26}