Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 1 | SUMMARY = "Software Construction tool (make/autotools replacement)" |
| 2 | HOMEPAGE = "https://github.com/SCons/scons" |
| 3 | SECTION = "devel/python" |
| 4 | LICENSE = "MIT" |
| 5 | LIC_FILES_CHKSUM = "file://LICENSE;md5=d903b0b8027f461402bac9b5169b36f7" |
| 6 | |
| 7 | SRC_URI += " file://0001-Fix-man-page-installation.patch" |
| 8 | SRC_URI[sha256sum] = "d47081587e3675cc168f1f54f0d74a69b328a2fc90ec4feb85f728677419b879" |
| 9 | |
| 10 | PYPI_PACKAGE = "SCons" |
| 11 | |
| 12 | inherit pypi setuptools3 |
| 13 | |
| 14 | RDEPENDS:${PN}:class-target = "\ |
| 15 | python3-core \ |
| 16 | python3-compression \ |
| 17 | python3-fcntl \ |
| 18 | python3-importlib-metadata \ |
| 19 | python3-io \ |
| 20 | python3-json \ |
| 21 | python3-shell \ |
| 22 | python3-pickle \ |
| 23 | python3-pkg-resources \ |
| 24 | python3-pprint \ |
| 25 | " |
| 26 | |
Andrew Geissler | 7e0e3c0 | 2022-02-25 20:34:39 +0000 | [diff] [blame] | 27 | do_install:append() { |
| 28 | install -d ${D}${mandir}/man1 |
| 29 | mv ${D}${prefix}/scons*.1 ${D}${mandir}/man1/ |
| 30 | } |
Andrew Geissler | 7e0e3c0 | 2022-02-25 20:34:39 +0000 | [diff] [blame] | 31 | |
| 32 | do_install:append:class-native() { |
| 33 | create_wrapper ${D}${bindir}/scons SCONS_LIB_DIR='${STAGING_DIR_HOST}/${PYTHON_SITEPACKAGES_DIR}' PYTHONNOUSERSITE='1' |
| 34 | } |
| 35 | |
| 36 | BBCLASSEXTEND = "native" |