Andrew Geissler | 7e0e3c0 | 2022-02-25 20:34:39 +0000 | [diff] [blame] | 1 | SUMMARY = "Display or change ethernet card settings" |
| 2 | DESCRIPTION = "A small utility for examining and tuning the settings of your ethernet-based network interfaces." |
| 3 | HOMEPAGE = "http://www.kernel.org/pub/software/network/ethtool/" |
| 4 | SECTION = "console/network" |
| 5 | LICENSE = "GPL-2.0-or-later" |
| 6 | LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \ |
| 7 | file://ethtool.c;beginline=4;endline=17;md5=c19b30548c582577fc6b443626fc1216" |
| 8 | |
| 9 | SRC_URI = "${KERNELORG_MIRROR}/software/network/ethtool/ethtool-${PV}.tar.gz \ |
| 10 | file://run-ptest \ |
| 11 | file://avoid_parallel_tests.patch \ |
| 12 | " |
| 13 | |
Andrew Geissler | 615f2f1 | 2022-07-15 14:00:58 -0500 | [diff] [blame] | 14 | SRC_URI[sha256sum] = "70091f95448eba851f9f9804059d0e237f1d909064046f9e3c6dc892aa1e8afe" |
Andrew Geissler | 7e0e3c0 | 2022-02-25 20:34:39 +0000 | [diff] [blame] | 15 | |
| 16 | UPSTREAM_CHECK_URI = "https://www.kernel.org/pub/software/network/ethtool/" |
| 17 | |
| 18 | inherit autotools ptest bash-completion pkgconfig |
| 19 | |
| 20 | RDEPENDS:${PN}-ptest += "make" |
| 21 | |
| 22 | PACKAGECONFIG ?= "netlink" |
| 23 | PACKAGECONFIG[netlink] = "--enable-netlink,--disable-netlink,libmnl," |
| 24 | |
| 25 | do_compile_ptest() { |
| 26 | oe_runmake buildtest-TESTS |
| 27 | } |
| 28 | |
| 29 | do_install_ptest () { |
| 30 | cp ${B}/Makefile ${D}${PTEST_PATH} |
| 31 | install ${B}/test-cmdline ${D}${PTEST_PATH} |
| 32 | if ${@bb.utils.contains('PACKAGECONFIG', 'netlink', 'false', 'true', d)}; then |
| 33 | install ${B}/test-features ${D}${PTEST_PATH} |
| 34 | fi |
| 35 | install ${B}/ethtool ${D}${PTEST_PATH}/ethtool |
| 36 | sed -i 's/^Makefile/_Makefile/' ${D}${PTEST_PATH}/Makefile |
| 37 | } |