Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 1 | SUMMARY = "Tools for managing Yocto Project style branched kernels" |
Andrew Geissler | 90fd73c | 2021-03-05 15:25:55 -0600 | [diff] [blame] | 2 | DESCRIPTION = "Powerful set of tools or managing Yocto Linux kernel sources \ |
| 3 | and configuration data. You can use these tools to make a single configuration \ |
| 4 | change, apply multiple patches, or work with your own kernel sources." |
| 5 | HOMEPAGE = "https://www.yoctoproject.org/" |
Patrick Williams | 03907ee | 2022-05-01 06:28:52 -0500 | [diff] [blame] | 6 | LICENSE = "GPL-2.0-only & MIT" |
| 7 | LIC_FILES_CHKSUM = "\ |
| 8 | file://tools/kgit;beginline=5;endline=9;md5=9c30e971d435e249624278c3e343e501 \ |
| 9 | file://Kconfiglib/LICENSE.txt;md5=712177a72a3937909543eda3ad1bfb7c \ |
| 10 | " |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 11 | |
| 12 | DEPENDS = "git-native" |
| 13 | |
Patrick Williams | 03907ee | 2022-05-01 06:28:52 -0500 | [diff] [blame] | 14 | SRCREV = "f70b1d52f4706a263ae22e2c61039ccd875e97b6" |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 15 | PV = "0.3+git${SRCPV}" |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 16 | |
| 17 | inherit native |
| 18 | |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 19 | SRC_URI = "git://git.yoctoproject.org/yocto-kernel-tools.git;branch=master" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 20 | S = "${WORKDIR}/git" |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 21 | |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 22 | do_configure() { |
| 23 | : |
| 24 | } |
| 25 | |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 26 | do_compile() { |
| 27 | : |
| 28 | } |
| 29 | |
| 30 | do_install() { |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 31 | oe_runmake DESTDIR=${D}${bindir} install |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 32 | } |