blob: 9619628c81539ac8e66f2a5a7337270a7dd68260 [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "GNOME Shell is the graphical shell of the GNOME desktop environment"
2LICENSE = "GPLv2"
3LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
4
5GNOMEBASEBUILDCLASS = "meson"
6
7inherit gnomebase gsettings gettext gobject-introspection features_check upstream-version-is-even bash-completion
8
9REQUIRED_DISTRO_FEATURES = "x11 polkit systemd pam"
10
11DEPENDS = " \
12 libxml2-native \
13 sassc-native \
14 gtk+3 \
15 mutter \
16 evolution-data-server \
17 gcr \
18 gjs \
19 gnome-autoar \
20 polkit \
21 libcroco \
22 startup-notification \
23 ibus \
24 gsettings-desktop-schemas \
25"
26
27GTKDOC_MESON_OPTION = "gtk_doc"
28
29# gobject-introspection is mandatory and cannot be configured
30REQUIRED_DISTRO_FEATURES += "gobject-introspection-data"
31UNKNOWN_CONFIGURE_WHITELIST_append = " introspection"
32
33SRC_URI[archive.md5sum] = "4bd27c8a91d30fde78cb69b94677cf1f"
34SRC_URI[archive.sha256sum] = "d296f318a74a6d7883358a6ce1c4d8808b7903dbbb4f9c61ab4230f18e6d7550"
35
36PACKAGECONFIG ??= "bluetooth nm ${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)}"
37PACKAGECONFIG[bluetooth] = ",,gnome-bluetooth"
38PACKAGECONFIG[nm] = "-Dnetworkmanager=true, -Dnetworkmanager=false, networkmanager"
39PACKAGECONFIG[systemd] = "-Dsystemd=true, -Dsystemd=false, systemd"
40
41EXTRA_OEMESON = " \
42 -Dman=false \
43"
44
45do_install_append() {
46 # fix shebangs
47 for tool in `find ${D}${bindir} -name '*-tool'`; do
48 sed -i 's:#!${PYTHON}:#!${bindir}/${PYTHON_PN}:' $tool
49 done
50}
51
52FILES_${PN} += " \
53 ${datadir}/dbus-1 \
54 ${datadir}/gnome-control-center \
55 ${datadir}/xdg-desktop-portal \
56 ${systemd_user_unitdir} \
57"
58
59RDEPENDS_${PN} += "gsettings-desktop-schemas gdm-base librsvg-gtk"
60
61PACKAGES =+ "${PN}-tools"
62FILES_${PN}-tools = "${bindir}/*-tool"
63RDEPENDS_${PN}-tools = "python3-core"
64