blob: 77be27ffaa5bf4502d615ebd9ae0809d61039aa0 [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "nanomsg-next-generation -- light-weight brokerless messaging"
2DESCRIPTION = "NNG, like its predecessors nanomsg (and to some extent ZeroMQ), is a lightweight, broker-less library, offering a simple API to solve common recurring messaging problems, such as publish/subscribe, RPC-style request/reply, or service discovery."
3HOMEPAGE = "https://github.com/nanomsg/nng"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=a19b15be6e844b39a54de2ef665bd6de"
6
7SECTION = "libs/networking"
8
9SRCREV = "53ae1a5ab37fdfc9ad5c236df3eaf4dd63f0fee9"
10
11SRC_URI = "git://github.com/nanomsg/nng.git;branch=v1.2.x"
12
13S = "${WORKDIR}/git"
14
15inherit cmake pkgconfig
16
17EXTRA_OECMAKE = "-DBUILD_SHARED_LIBS=ON"
18
19PACKAGECONFIG ??= ""
20
21PACKAGECONFIG[mbedtls] = "-DNNG_ENABLE_TLS=ON,-DNNG_ENABLE_TLS=OFF,mbedtls"