Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame^] | 1 | SUMMARY = "nanomsg-next-generation -- light-weight brokerless messaging" |
| 2 | DESCRIPTION = "NNG, like its predecessors nanomsg (and to some extent ZeroMQ), is a lightweight, broker-less library, offering a simple API to solve common recurring messaging problems, such as publish/subscribe, RPC-style request/reply, or service discovery." |
| 3 | HOMEPAGE = "https://github.com/nanomsg/nng" |
| 4 | LICENSE = "MIT" |
| 5 | LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=a19b15be6e844b39a54de2ef665bd6de" |
| 6 | |
| 7 | SECTION = "libs/networking" |
| 8 | |
| 9 | SRCREV = "53ae1a5ab37fdfc9ad5c236df3eaf4dd63f0fee9" |
| 10 | |
| 11 | SRC_URI = "git://github.com/nanomsg/nng.git;branch=v1.2.x" |
| 12 | |
| 13 | S = "${WORKDIR}/git" |
| 14 | |
| 15 | inherit cmake pkgconfig |
| 16 | |
| 17 | EXTRA_OECMAKE = "-DBUILD_SHARED_LIBS=ON" |
| 18 | |
| 19 | PACKAGECONFIG ??= "" |
| 20 | |
| 21 | PACKAGECONFIG[mbedtls] = "-DNNG_ENABLE_TLS=ON,-DNNG_ENABLE_TLS=OFF,mbedtls" |