blob: db7b0d486b74bd92786191cd9ce2508a06830e6d [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "wolfSSL Lightweight Embedded SSL/TLS Library"
2DESCRIPTION = "wolfSSL, formerly CyaSSL, is a lightweight SSL library written \
3 in C and optimized for embedded and RTOS environments. It can \
4 be up to 20 times smaller than OpenSSL while still supporting \
5 a full TLS client and server, up to TLS 1.3"
6HOMEPAGE = "https://www.wolfssl.com/products/wolfssl"
7BUGTRACKER = "https://github.com/wolfssl/wolfssl/issues"
8SECTION = "libs"
9LICENSE = "GPLv2"
10LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
11
12PROVIDES += "cyassl"
13RPROVIDES_${PN} = "cyassl"
14
15SRC_URI = "git://github.com/wolfSSL/wolfssl.git;protocol=https"
16SRCREV = "e116c89a58af750421d82ece13f80516d2bde02e"
17S = "${WORKDIR}/git"
18
19inherit autotools
20
21BBCLASSEXTEND += "native nativesdk"