Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 1 | SUMMARY = "Babel is a loop-avoiding distance-vector routing protocol" |
| 2 | DESCRIPTION = "\ |
| 3 | Babel is a loop-avoiding distance-vector routing protocol for IPv6 and \ |
| 4 | IPv4 with fast convergence properties. It is based on the ideas in DSDV, AODV \ |
| 5 | and Cisco's EIGRP, but is designed to work well not only in wired networks \ |
| 6 | but also in wireless mesh networks, and has been extended with support \ |
| 7 | for overlay networks. Babel is in the process of becoming an IETF Standard. \ |
| 8 | " |
| 9 | HOMEPAGE = "https://www.irif.fr/~jch/software/babel/" |
| 10 | SECTION = "net" |
| 11 | |
| 12 | LICENSE = "MIT" |
| 13 | LIC_FILES_CHKSUM = "file://LICENCE;md5=411a48ac3c2e9e0911b8dd9aed26f754" |
| 14 | |
| 15 | SRC_URI = "git://github.com/jech/babeld.git;protocol=git" |
Brad Bishop | 868407c | 2019-11-04 13:24:47 -0500 | [diff] [blame] | 16 | SRCREV = "0835d5d894ea016ab7b81562466cade2c51a12d4" |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 17 | |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame^] | 18 | UPSTREAM_CHECK_GITTAGREGEX = "babeld-(?P<pver>\d+(\.\d+)+)" |
| 19 | |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 20 | S = "${WORKDIR}/git" |
| 21 | |
| 22 | do_compile () { |
| 23 | oe_runmake babeld |
| 24 | } |
| 25 | |
| 26 | do_install () { |
| 27 | oe_runmake install.minimal PREFIX=${D} |
| 28 | } |
| 29 | |