Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame^] | 1 | SUMMARY = "NVMe management command line interface" |
| 2 | AUTHOR = "Stefan Wiehler <stefan.wiehler@missinglinkelectronics.com>" |
| 3 | HOMEPAGE = "https://github.com/linux-nvme/nvme-cli" |
| 4 | SECTION = "console/utils" |
| 5 | LICENSE = "GPLv2" |
| 6 | LIC_FILES_CHKSUM = "file://LICENSE;md5=8264535c0c4e9c6c335635c4026a8022" |
| 7 | DEPENDS = "util-linux" |
| 8 | PV .= "+git${SRCPV}" |
| 9 | |
| 10 | SRC_URI = "git://github.com/linux-nvme/nvme-cli.git \ |
| 11 | file://0001-fix-musl-compilation.patch \ |
| 12 | " |
| 13 | SRCREV = "1d84d6ae0c7d7ceff5a73fe174dde8b0005f6108" |
| 14 | |
| 15 | S = "${WORKDIR}/git" |
| 16 | |
| 17 | inherit bash-completion systemd |
| 18 | |
| 19 | do_install() { |
| 20 | oe_runmake install-spec DESTDIR=${D} PREFIX=${prefix} \ |
| 21 | UDEVDIR=${nonarch_base_libdir}/udev SYSTEMDDIR=${systemd_unitdir} |
| 22 | } |
| 23 | |
| 24 | pkg_postinst_ontarget_${PN}() { |
| 25 | ${sbindir}/nvme gen-hostnqn > ${sysconfdir}/nvme/hostnqn |
| 26 | ${bindir}/uuidgen > ${sysconfdir}/nvme/hostid |
| 27 | } |
| 28 | |
| 29 | PACKAGES =+ "${PN}-dracut ${PN}-zsh-completion" |
| 30 | |
| 31 | FILES_${PN} += "${systemd_system_unitdir}" |
| 32 | FILES_${PN}-dracut = "${nonarch_libdir}/dracut/dracut.conf.d" |
| 33 | FILES_${PN}-zsh-completion = "${datadir}/zsh/site-functions" |
| 34 | |
| 35 | RDEPENDS_${PN} = "util-linux-uuidgen" |