Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 1 | SUMMARY = "A New System Troubleshooting Tool Built for the Way You Work" |
| 2 | DESCRIPTION = "Sysdig is open source, system-level exploration: capture \ |
| 3 | system state and activity from a running Linux instance, then save, \ |
| 4 | filter and analyze." |
| 5 | HOMEPAGE = "http://www.sysdig.org/" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame^] | 6 | LICENSE = "Apache-2.0 & (MIT | GPL-2.0)" |
| 7 | LIC_FILES_CHKSUM = "file://COPYING;md5=f8fee3d59797546cffab04f3b88b2d44" |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 8 | |
| 9 | inherit cmake pkgconfig |
| 10 | |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame^] | 11 | #OECMAKE_GENERATOR = "Unix Makefiles" |
| 12 | JIT ?= "jit" |
| 13 | JIT_mipsarchn32 = "" |
| 14 | JIT_mipsarchn64 = "" |
| 15 | JIT_riscv64 = "" |
| 16 | JIT_riscv32 = "" |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 17 | |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame^] | 18 | DEPENDS += "lua${JIT} zlib c-ares grpc-native grpc curl ncurses jsoncpp tbb jq openssl elfutils protobuf protobuf-native jq-native" |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 19 | RDEPENDS_${PN} = "bash" |
| 20 | |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame^] | 21 | SRC_URI = "git://github.com/draios/sysdig.git;branch=dev \ |
| 22 | file://0001-fix-build-with-LuaJIT-2.1-betas.patch \ |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 23 | file://0001-Fix-build-with-musl-backtrace-APIs-are-glibc-specifi.patch \ |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame^] | 24 | file://fix-uint64-const.patch \ |
| 25 | file://aarch64.patch \ |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 26 | " |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame^] | 27 | SRCREV = "8daeef8da752c5f07f439391bc20c5948eb11470" |
| 28 | PV = "0.26.6" |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 29 | |
| 30 | S = "${WORKDIR}/git" |
| 31 | |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame^] | 32 | EXTRA_OECMAKE = "\ |
| 33 | -DBUILD_DRIVER=OFF \ |
| 34 | -DUSE_BUNDLED_DEPS=OFF \ |
| 35 | -DUSE_BUNDLED_B64=ON \ |
| 36 | -DCREATE_TEST_TARGETS=OFF \ |
| 37 | -DDIR_ETC=${sysconfdir} \ |
| 38 | -DLUA_INCLUDE_DIR=${STAGING_INCDIR}/luajit-2.1 \ |
| 39 | -DLUA_LIBRARY=libluajit-5.1.so \ |
| 40 | " |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 41 | |
| 42 | FILES_${PN} += " \ |
| 43 | ${DIR_ETC}/* \ |
Patrick Williams | ddad1a1 | 2017-02-23 20:36:32 -0600 | [diff] [blame] | 44 | ${datadir}/zsh/* \ |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 45 | ${prefix}/src/* \ |
| 46 | " |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame^] | 47 | # Use getaddrinfo_a is a GNU extension in libsinsp |
| 48 | # It should be fixed in sysdig, until then disable |
| 49 | # on musl |
| 50 | # Something like this https://code.videolan.org/ePirat/vlc/-/commit/01fd9fe4c7f6c5558f7345f38abf0152e17853ab is needed to fix it |
| 51 | COMPATIBLE_HOST_libc-musl = "null" |
| 52 | COMPATIBLE_HOST_mips = "null" |
| 53 | COMPATIBLE_HOST_riscv64 = "null" |
| 54 | COMPATIBLE_HOST_riscv32 = "null" |