blob: 6de704d0b7a8d7b8b04bba26615080250fa2e8b1 [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001require recipes-graphics/xorg-app/xorg-app-common.inc
2SUMMARY = "xterm is the standard terminal emulator for the X Window System"
3DEPENDS = "libxaw xorgproto libxext libxau libxinerama libxpm ncurses"
4
5LIC_FILES_CHKSUM = "file://xterm.h;beginline=3;endline=31;md5=996b1ce0584c0747b17b57654cc81e8e"
6
7SRC_URI = "http://invisible-mirror.net/archives/${BPN}/${BP}.tgz \
8 file://0001-Add-configure-time-check-for-setsid.patch \
9 "
10
11SRC_URI[md5sum] = "247c30ebfa44623f3a2d100e0cae5c7f"
12SRC_URI[sha256sum] = "e521d3ee9def61f5d5c911afc74dd5c3a56ce147c7071c74023ea24cac9bb768"
13PACKAGECONFIG ?= ""
14PACKAGECONFIG[xft] = "--enable-freetype,--disable-freetype,libxft fontconfig freetype-native"
15
16EXTRA_OECONF = " --x-includes=${STAGING_INCDIR} \
17 --x-libraries=${STAGING_LIBDIR} \
18 FREETYPE_CONFIG=${STAGING_BINDIR_CROSS}/freetype-config \
19 --disable-imake \
20 --disable-rpath-hack \
21 --disable-setuid \
22 --with-app-defaults=${datadir}/X11/app-defaults \
23 "
24
25B = "${S}"
26
27do_configure() {
28 gnu-configize --force
29 sed -e "s%/usr/contrib/X11R6%${STAGING_LIBDIR}%g" -i configure
30 oe_runconf
31}
32
33# busybox can supply resize too
34inherit update-alternatives
35
36ALTERNATIVE_${PN} = "resize"