Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame^] | 1 | SUMMARY = "Multimedia processing server for Linux" |
| 2 | AUTHOR = "Wim Taymans <wtaymans@redhat.com>" |
| 3 | HOMEPAGE = "https://pipewire.org" |
| 4 | SECTION = "multimedia" |
| 5 | LICENSE = "LGPL-2.1" |
| 6 | LIC_FILES_CHKSUM = " \ |
| 7 | file://LICENSE;md5=d8153c6e65986f862a0550ca74a3ed73 \ |
| 8 | file://LGPL;md5=2d5025d4aa3495befef8f17206a5b0a1 \ |
| 9 | " |
| 10 | DEPENDS = "alsa-lib dbus udev" |
| 11 | SRCREV = "14c11c0fe4d366bad4cfecdee97b6652ff9ed63d" |
| 12 | PV = "0.2.7" |
| 13 | |
| 14 | SRC_URI = "git://github.com/PipeWire/pipewire" |
| 15 | |
| 16 | S = "${WORKDIR}/git" |
| 17 | |
| 18 | inherit meson pkgconfig systemd manpages |
| 19 | |
| 20 | PACKAGECONFIG ??= "\ |
| 21 | ${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)} \ |
| 22 | gstreamer \ |
| 23 | " |
| 24 | |
| 25 | PACKAGECONFIG[systemd] = "-Dsystemd=true,-Dsystemd=false,systemd" |
| 26 | PACKAGECONFIG[gstreamer] = "-Dgstreamer=enabled,-Dgstreamer=disabled,glib-2.0 gstreamer1.0 gstreamer1.0-plugins-base" |
| 27 | PACKAGECONFIG[manpages] = "-Dman=true,-Dman=false,libxml-parser-perl-native" |
| 28 | |
| 29 | PACKAGES =+ "\ |
| 30 | ${PN}-spa-plugins \ |
| 31 | ${PN}-alsa \ |
| 32 | ${PN}-config \ |
| 33 | gstreamer1.0-${PN} \ |
| 34 | lib${PN} \ |
| 35 | lib${PN}-modules \ |
| 36 | " |
| 37 | |
| 38 | RDEPENDS_lib${PN} += "lib${PN}-modules ${PN}-spa-plugins" |
| 39 | |
| 40 | FILES_${PN} = "\ |
| 41 | ${sysconfdir}/pipewire/pipewire.conf \ |
| 42 | ${bindir}/pipewire* \ |
| 43 | ${systemd_user_unitdir}/* \ |
| 44 | " |
| 45 | FILES_lib${PN} = "\ |
| 46 | ${libdir}/libpipewire-*.so.* \ |
| 47 | " |
| 48 | FILES_lib${PN}-modules = "\ |
| 49 | ${libdir}/pipewire-*/* \ |
| 50 | " |
| 51 | FILES_${PN}-spa-plugins = "\ |
| 52 | ${bindir}/spa-* \ |
| 53 | ${libdir}/spa/* \ |
| 54 | " |
| 55 | FILES_${PN}-alsa = "\ |
| 56 | ${libdir}/alsa-lib/* \ |
| 57 | ${datadir}/alsa/alsa.conf.d/50-pipewire.conf \ |
| 58 | " |
| 59 | FILES_gstreamer1.0-${PN} = "\ |
| 60 | ${libdir}/gstreamer-1.0/* \ |
| 61 | " |
| 62 | |
| 63 | CONFFILES_${PN} = "\ |
| 64 | ${sysconfdir}/pipewire/pipewire.conf \ |
| 65 | " |