blob: 94976d2e984064c5327d55d2471c38f81f3780e7 [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001DESCRIPTION = "A small C library that is supposed to make it easy to run an HTTP server as part of another application"
2HOMEPAGE = "http://www.gnu.org/software/libmicrohttpd/"
3LICENSE = "LGPL-2.1+"
4LIC_FILES_CHKSUM = "file://COPYING;md5=57d09285feac8a64efa878e692b14f36"
5SECTION = "net"
6
7DEPENDS = "file"
8
9SRC_URI = "${GNU_MIRROR}/libmicrohttpd/${BPN}-${PV}.tar.gz \
10"
11SRC_URI[md5sum] = "dcd6045ecb4ea18c120afedccbd1da74"
12SRC_URI[sha256sum] = "90d0a3d396f96f9bc41eb0f7e8187796049285fabef82604acd4879590977307"
13
14inherit autotools lib_package pkgconfig gettext
15
16CFLAGS += "-pthread -D_REENTRANT"
17
18EXTRA_OECONF += "--disable-static --with-gnutls=${STAGING_LIBDIR}/../"
19
20PACKAGECONFIG ?= "curl https"
21PACKAGECONFIG_append_class-target = "\
22 ${@bb.utils.filter('DISTRO_FEATURES', 'largefile', d)} \
23"
24PACKAGECONFIG[largefile] = "--enable-largefile,--disable-largefile,,"
25PACKAGECONFIG[curl] = "--enable-curl,--disable-curl,curl,"
26PACKAGECONFIG[https] = "--enable-https,--disable-https,libgcrypt gnutls,"
27
28do_compile_append() {
29 sed -i s:-L${STAGING_LIBDIR}::g libmicrohttpd.pc
30}