Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame^] | 1 | SUMMARY = "C++/Boost Asio based websocket client/server library." |
| 2 | SECTION = "libs/network" |
| 3 | HOMEPAGE = "https://github.com/zaphoyd/websocketpp" |
| 4 | LICENSE = "BSD-3-Clause" |
| 5 | LIC_FILES_CHKSUM = "file://${S}/COPYING;md5=4d168d763c111f4ffc62249870e4e0ea" |
| 6 | |
| 7 | DEPENDS = " ${@bb.utils.contains('DISTRO_FEATURES', 'ptest', 'openssl boost zlib', '', d)} " |
| 8 | |
| 9 | SRC_URI = "git://github.com/zaphoyd/websocketpp.git;protocol=https \ |
| 10 | file://0001-cmake-Use-GNUInstallDirs.patch \ |
| 11 | file://855.patch \ |
| 12 | file://857.patch \ |
| 13 | file://0001-Correct-clang-compiler-flags.patch \ |
| 14 | " |
| 15 | |
| 16 | EXTRA_OECMAKE = "${@bb.utils.contains('DISTRO_FEATURES', 'ptest', '-DBUILD_EXAMPLES=ON -DBUILD_TESTS=ON', '', d)} " |
| 17 | |
| 18 | # this is an header only library, do not depend on the main package |
| 19 | RDEPENDS_${PN}-dev = "" |
| 20 | |
| 21 | # to add this package to an SDK, since it isn't a reverse-dependency of anything, just use something like this: |
| 22 | # TOOLCHAIN_TARGET_TASK_append = " websocketpp-dev" |
| 23 | |
| 24 | # tag 0.8.2 |
| 25 | SRCREV= "56123c87598f8b1dd471be83ca841ceae07f95ba" |
| 26 | |
| 27 | S = "${WORKDIR}/git" |
| 28 | |
| 29 | inherit cmake |
| 30 | |
| 31 | PACKAGES =+ "${PN}-examples" |
| 32 | |
| 33 | FILES_${PN}-examples = "${docdir}" |
| 34 | |
| 35 | do_install_append() { |
| 36 | install -d ${D}${docdir}/${BPN} |
| 37 | cp -R ${S}/examples ${D}${docdir}/${BPN} |
| 38 | } |