Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame^] | 1 | SUMMARY = "Supervisor: A Process Control System" |
| 2 | DESCRIPTION = "\ |
| 3 | Supervisor is a client/server system that allows its users \ |
| 4 | to monitorand control a number of processes on UNIX-like \ |
| 5 | operating systems." |
| 6 | HOMEPAGE = "https://github.com/Supervisor/supervisor" |
| 7 | LICENSE = "BSD-4-Clause" |
| 8 | LIC_FILES_CHKSUM = "file://LICENSES.txt;md5=5b4e3a2172bba4c47cded5885e7e507e" |
| 9 | |
| 10 | SRC_URI[md5sum] = "ecea94eedc70ba5127fdeb0665bcca0d" |
| 11 | SRC_URI[sha256sum] = "2dc86fe0476e945e61483d614ceb2cf4f93b95282eb243bdf792621994360383" |
| 12 | |
| 13 | PYPI_PACKAGE = "supervisor" |
| 14 | inherit pypi systemd setuptools3 |
| 15 | RDEPENDS_${PN} = "\ |
| 16 | ${PYTHON_PN}-meld3 \ |
| 17 | " |
| 18 | |
| 19 | SRC_URI += "file://supervisord.conf \ |
| 20 | file://supervisor.service \ |
| 21 | " |
| 22 | SYSTEMD_SERVICE_${PN} = "supervisor.service" |
| 23 | |
| 24 | do_install_append() { |
| 25 | install -d ${D}${sysconfdir}/supervisor |
| 26 | install -d ${D}${systemd_system_unitdir} |
| 27 | |
| 28 | install -m 0644 ${WORKDIR}/supervisord.conf ${D}${sysconfdir}/supervisor |
| 29 | install -m 0644 ${WORKDIR}/supervisor.service ${D}${systemd_system_unitdir} |
| 30 | } |