Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame^] | 1 | SUMMARY = "Power manager for the Xfce desktop environment" |
| 2 | HOMEPAGE = "http://goodies.xfce.org/projects/applications/xfce4-power-manager" |
| 3 | SECTION = "x11" |
| 4 | |
| 5 | LICENSE = "GPLv2+" |
| 6 | LIC_FILES_CHKSUM = "file://COPYING;md5=59530bdf33659b29e73d4adb9f9f6552" |
| 7 | |
| 8 | inherit xfce features_check |
| 9 | |
| 10 | REQUIRED_DISTRO_FEATURES = "x11" |
| 11 | |
| 12 | DEPENDS += "libnotify libxrandr virtual/libx11 libxext xfce4-panel upower libxscrnsaver" |
| 13 | |
| 14 | SRC_URI[md5sum] = "19873fc8a6de5e37ed57036a0002a5ce" |
| 15 | SRC_URI[sha256sum] = "1b7bf0d3e8af69b10f7b6a518451e01fc7888e0d9d360bc33f6c89179bb6080b" |
| 16 | |
| 17 | EXTRA_OECONF = " \ |
| 18 | --enable-network-manager \ |
| 19 | --enable-panel-plugins \ |
| 20 | " |
| 21 | |
| 22 | PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'polkit', d)}" |
| 23 | PACKAGECONFIG[polkit] = "--enable-polkit, --disable-polkit, polkit" |
| 24 | |
| 25 | PACKAGES += "xfce4-powermanager-plugin" |
| 26 | |
| 27 | FILES_${PN} += " \ |
| 28 | ${datadir}/polkit-1 \ |
| 29 | ${datadir}/metainfo \ |
| 30 | " |
| 31 | |
| 32 | FILES_xfce4-powermanager-plugin = " \ |
| 33 | ${libdir}/xfce4 \ |
| 34 | ${datadir}/xfce4 \ |
| 35 | " |
| 36 | |
| 37 | RDEPENDS_xfce4-powermanager-plugin = "${PN}" |
| 38 | RDEPENDS_${PN} = "networkmanager ${@bb.utils.contains('DISTRO_FEATURES','systemd','','consolekit',d)}" |
| 39 | |
| 40 | # xfce4-brightness-plugin was replaced by xfce4-powermanager-plugin |
| 41 | RPROVIDES_xfce4-powermanager-plugin += "xfce4-brightness-plugin" |
| 42 | RREPLACES_xfce4-powermanager-plugin += "xfce4-brightness-plugin" |
| 43 | RCONFLICTS_xfce4-powermanager-plugin += "xfce4-brightness-plugin" |