Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 1 | SUMMARY = "Library providing simplified C and Python API to libsolv" |
| 2 | LICENSE = "LGPLv2.1" |
| 3 | LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c" |
| 4 | |
| 5 | SRC_URI = "git://github.com/rpm-software-management/libdnf \ |
| 6 | file://0001-FindGtkDoc.cmake-drop-the-requirement-for-GTKDOC_SCA.patch \ |
| 7 | file://0004-Set-libsolv-variables-with-pkg-config-cmake-s-own-mo.patch \ |
| 8 | file://0001-Get-parameters-for-both-libsolv-and-libsolvext-libdn.patch \ |
| 9 | file://0001-Add-WITH_TESTS-option.patch \ |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame^] | 10 | file://0001-include-stdexcept-for-runtime_error.patch \ |
| 11 | file://fix-deprecation-warning.patch \ |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 12 | " |
| 13 | |
| 14 | SRCREV = "751f89045b80d58c0d05800f74357cf78cdf7e77" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame^] | 15 | UPSTREAM_CHECK_GITTAGREGEX = "(?P<pver>\d+(\.\d+)+)" |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 16 | |
| 17 | S = "${WORKDIR}/git" |
| 18 | |
Brad Bishop | f3f93bb | 2019-10-16 14:33:32 -0400 | [diff] [blame] | 19 | DEPENDS = "glib-2.0 libsolv libcheck librepo rpm gtk-doc libmodulemd-v1 json-c swig-native" |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 20 | |
| 21 | inherit gtk-doc gobject-introspection cmake pkgconfig distutils3-base |
| 22 | |
| 23 | EXTRA_OECMAKE = " -DPYTHON_INSTALL_DIR=${PYTHON_SITEPACKAGES_DIR} -DWITH_MAN=OFF -DPYTHON_DESIRED=3 \ |
| 24 | ${@bb.utils.contains('GI_DATA_ENABLED', 'True', '-DWITH_GIR=ON', '-DWITH_GIR=OFF', d)} \ |
| 25 | -DWITH_TESTS=OFF \ |
| 26 | " |
| 27 | EXTRA_OECMAKE_append_class-native = " -DWITH_GIR=OFF" |
| 28 | EXTRA_OECMAKE_append_class-nativesdk = " -DWITH_GIR=OFF" |
| 29 | |
| 30 | BBCLASSEXTEND = "native nativesdk" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame^] | 31 | PNBLACKLIST[libdnf] ?= "${@bb.utils.contains('PACKAGE_CLASSES', 'package_rpm', '', 'Does not build without package_rpm in PACKAGE_CLASSES due disabled rpm support in libsolv', d)}" |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 32 | |