blob: 152ff02a25f7c9d01da56e5025784061d1c714ef [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001SUMMARY = "File synchronization tool"
2HOMEPAGE = "http://rsync.samba.org/"
3BUGTRACKER = "http://rsync.samba.org/bugzilla.html"
4SECTION = "console/network"
Brad Bishop316dfdd2018-06-25 12:45:53 -04005# GPLv2+ (<< 3.0.0), GPLv3+ (>= 3.0.0)
6LICENSE = "GPLv3+"
7LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
8
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08009DEPENDS = "popt"
10
11SRC_URI = "https://download.samba.org/pub/${BPN}/src/${BP}.tar.gz \
12 file://rsyncd.conf \
13 file://makefile-no-rebuild.patch \
Brad Bishop96ff1982019-08-19 13:50:42 -040014 file://CVE-2016-9840.patch \
15 file://CVE-2016-9841.patch \
16 file://CVE-2016-9842.patch \
17 file://CVE-2016-9843.patch \
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080018"
19
20SRC_URI[md5sum] = "1581a588fde9d89f6bc6201e8129afaf"
21SRC_URI[sha256sum] = "55cc554efec5fdaad70de921cd5a5eeb6c29a95524c715f3bbf849235b0800c0"
22
Andrew Geissler82c905d2020-04-13 13:39:40 -050023# -16548 required for v3.1.3pre1. Already in v3.1.3.
24CVE_CHECK_WHITELIST += " CVE-2017-16548 "
25
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080026inherit autotools
27
Brad Bishop316dfdd2018-06-25 12:45:53 -040028PACKAGECONFIG ??= "acl attr \
29 ${@bb.utils.filter('DISTRO_FEATURES', 'ipv6', d)} \
30"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080031
Brad Bishop316dfdd2018-06-25 12:45:53 -040032PACKAGECONFIG[acl] = "--enable-acl-support,--disable-acl-support,acl,"
33PACKAGECONFIG[attr] = "--enable-xattr-support,--disable-xattr-support,attr,"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080034PACKAGECONFIG[ipv6] = "--enable-ipv6,--disable-ipv6,"
Brad Bishop316dfdd2018-06-25 12:45:53 -040035
36# By default, if crosscompiling, rsync disables a number of
37# capabilities, hardlinking symlinks and special files (i.e. devices)
38CACHED_CONFIGUREVARS += "rsync_cv_can_hardlink_special=yes rsync_cv_can_hardlink_symlink=yes"
39
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080040EXTRA_OEMAKE = 'STRIP=""'
41
Brad Bishop316dfdd2018-06-25 12:45:53 -040042# rsync 3.0 uses configure.sh instead of configure, and
43# makefile checks the existence of configure.sh
44do_configure_prepend () {
45 rm -f ${S}/configure ${S}/configure.sh
46}
47
48do_configure_append () {
49 cp -f ${S}/configure ${S}/configure.sh
50}
51
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080052do_install_append() {
53 install -d ${D}${sysconfdir}
54 install -m 0644 ${WORKDIR}/rsyncd.conf ${D}${sysconfdir}
55}
56
Brad Bishop316dfdd2018-06-25 12:45:53 -040057BBCLASSEXTEND = "native"