Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 1 | SUMMARY = "Valgrind memory debugger and instrumentation framework" |
| 2 | HOMEPAGE = "http://valgrind.org/" |
| 3 | BUGTRACKER = "http://valgrind.org/support/bug_reports.html" |
| 4 | LICENSE = "GPLv2 & GPLv2+ & BSD" |
| 5 | LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \ |
| 6 | file://include/pub_tool_basics.h;beginline=6;endline=29;md5=d4de0407239381463cf01dd276d7c22e \ |
| 7 | file://include/valgrind.h;beginline=1;endline=56;md5=ad3b317f3286b6b704575d9efe6ca5df \ |
| 8 | file://COPYING.DOCS;md5=24ea4c7092233849b4394699333b5c56" |
| 9 | |
Brad Bishop | 96ff198 | 2019-08-19 13:50:42 -0400 | [diff] [blame] | 10 | DEPENDS = " \ |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 11 | ${@bb.utils.contains('DISTRO_FEATURES', 'ptest', 'boost', '', d)} \ |
| 12 | " |
| 13 | |
| 14 | SRC_URI = "https://sourceware.org/pub/valgrind/valgrind-${PV}.tar.bz2 \ |
| 15 | file://fixed-perl-path.patch \ |
| 16 | file://Added-support-for-PPC-instructions-mfatbu-mfatbl.patch \ |
| 17 | file://run-ptest \ |
Brad Bishop | a34c030 | 2019-09-23 22:34:48 -0400 | [diff] [blame] | 18 | file://remove-for-aarch64 \ |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 19 | file://0004-Fix-out-of-tree-builds.patch \ |
| 20 | file://0005-Modify-vg_test-wrapper-to-support-PTEST-formats.patch \ |
| 21 | file://0001-Remove-tests-that-fail-to-build-on-some-PPC32-config.patch \ |
| 22 | file://use-appropriate-march-mcpu-mfpu-for-ARM-test-apps.patch \ |
| 23 | file://avoid-neon-for-targets-which-don-t-support-it.patch \ |
| 24 | file://valgrind-make-ld-XXX.so-strlen-intercept-optional.patch \ |
| 25 | file://0001-makefiles-Drop-setting-mcpu-to-cortex-a8-on-arm-arch.patch \ |
| 26 | file://0001-str_tester.c-Limit-rawmemchr-test-to-glibc.patch \ |
| 27 | file://0001-sigqueue-Rename-_sifields-to-__si_fields-on-musl.patch \ |
| 28 | file://0002-context-APIs-are-not-available-on-musl.patch \ |
| 29 | file://0003-correct-include-directive-path-for-config.h.patch \ |
| 30 | file://0004-pth_atfork1.c-Define-error-API-for-musl.patch \ |
| 31 | file://0005-tc20_verifywrap.c-Fake-__GLIBC_PREREQ-with-musl.patch \ |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 32 | file://0001-memcheck-arm64-Define-__THROW-if-not-already-defined.patch \ |
| 33 | file://0002-memcheck-x86-Define-__THROW-if-not-defined.patch \ |
| 34 | file://0003-tests-seg_override-Replace-__modify_ldt-with-syscall.patch \ |
| 35 | file://0001-fix-opcode-not-supported-on-mips32-linux.patch \ |
| 36 | file://0001-Guard-against-__GLIBC_PREREQ-for-musl-libc.patch \ |
| 37 | file://0001-Make-local-functions-static-to-avoid-assembler-error.patch \ |
| 38 | file://0001-Return-a-valid-exit_code-from-vg_regtest.patch \ |
| 39 | file://0001-valgrind-filter_xml_frames-do-not-filter-usr.patch \ |
Brad Bishop | a34c030 | 2019-09-23 22:34:48 -0400 | [diff] [blame] | 40 | file://0001-adjust-path-filter-for-2-memcheck-tests.patch \ |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame^] | 41 | file://s390x_vec_op_t.patch \ |
| 42 | file://0001-none-tests-fdleak_cmsg.stderr.exp-adjust-tmp-paths.patch \ |
| 43 | file://0001-tests-Make-pthread_detatch-call-portable-across-plat.patch \ |
| 44 | file://0001-memcheck-tests-Fix-timerfd-syscall-test.patch \ |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 45 | " |
| 46 | SRC_URI[md5sum] = "46e5fbdcbc3502a5976a317a0860a975" |
| 47 | SRC_URI[sha256sum] = "417c7a9da8f60dd05698b3a7bc6002e4ef996f14c13f0ff96679a16873e78ab1" |
| 48 | UPSTREAM_CHECK_REGEX = "valgrind-(?P<pver>\d+(\.\d+)+)\.tar" |
| 49 | |
| 50 | COMPATIBLE_HOST = '(i.86|x86_64|arm|aarch64|mips|powerpc|powerpc64).*-linux' |
| 51 | |
| 52 | # valgrind supports armv7 and above |
| 53 | COMPATIBLE_HOST_armv4 = 'null' |
| 54 | COMPATIBLE_HOST_armv5 = 'null' |
| 55 | COMPATIBLE_HOST_armv6 = 'null' |
| 56 | |
| 57 | # X32 isn't supported by valgrind at this time |
| 58 | COMPATIBLE_HOST_linux-gnux32 = 'null' |
| 59 | COMPATIBLE_HOST_linux-muslx32 = 'null' |
| 60 | |
| 61 | # Disable for some MIPS variants |
| 62 | COMPATIBLE_HOST_mipsarchr6 = 'null' |
| 63 | COMPATIBLE_HOST_linux-gnun32 = 'null' |
| 64 | |
| 65 | # Disable for powerpc64 with musl |
| 66 | COMPATIBLE_HOST_libc-musl_powerpc64 = 'null' |
| 67 | |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame^] | 68 | # brokenseip is unfortunately required by ptests to pass |
| 69 | inherit autotools-brokensep ptest multilib_header |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 70 | |
| 71 | EXTRA_OECONF = "--enable-tls --without-mpicc" |
| 72 | EXTRA_OECONF += "${@['--enable-only32bit','--enable-only64bit'][d.getVar('SITEINFO_BITS') != '32']}" |
| 73 | |
| 74 | # valgrind checks host_cpu "armv7*)", so we need to over-ride the autotools.bbclass default --host option |
| 75 | EXTRA_OECONF_append_arm = " --host=armv7${HOST_VENDOR}-${HOST_OS}" |
| 76 | |
| 77 | EXTRA_OEMAKE = "-w" |
| 78 | |
| 79 | CACHED_CONFIGUREVARS += "ac_cv_path_PERL='/usr/bin/env perl'" |
| 80 | |
| 81 | # valgrind likes to control its own optimisation flags. It generally defaults |
| 82 | # to -O2 but uses -O0 for some specific test apps etc. Passing our own flags |
| 83 | # (via CFLAGS) means we interfere with that. Only pass DEBUG_FLAGS to it |
| 84 | # which fixes build path issue in DWARF. |
| 85 | SELECTED_OPTIMIZATION = "${DEBUG_FLAGS}" |
| 86 | |
| 87 | do_configure_prepend () { |
| 88 | rm -rf ${S}/config.h |
| 89 | sed -i -e 's:$(abs_top_builddir):$(pkglibdir)/ptest:g' ${S}/none/tests/Makefile.am |
| 90 | sed -i -e 's:$(top_builddir):$(pkglibdir)/ptest:g' ${S}/memcheck/tests/Makefile.am |
| 91 | } |
| 92 | |
| 93 | do_install_append () { |
| 94 | install -m 644 ${B}/default.supp ${D}/${libdir}/valgrind/ |
| 95 | oe_multilib_header valgrind/config.h |
| 96 | } |
| 97 | |
| 98 | VALGRINDARCH ?= "${TARGET_ARCH}" |
| 99 | VALGRINDARCH_aarch64 = "arm64" |
| 100 | VALGRINDARCH_x86-64 = "amd64" |
| 101 | VALGRINDARCH_x86 = "x86" |
| 102 | VALGRINDARCH_mips = "mips32" |
| 103 | VALGRINDARCH_mipsel = "mips32" |
| 104 | VALGRINDARCH_mips64el = "mips64" |
| 105 | VALGRINDARCH_powerpc = "ppc" |
| 106 | VALGRINDARCH_powerpc64 = "ppc64" |
| 107 | VALGRINDARCH_powerpc64el = "ppc64le" |
| 108 | |
| 109 | INHIBIT_PACKAGE_STRIP_FILES = "${PKGD}${libdir}/valgrind/vgpreload_memcheck-${VALGRINDARCH}-linux.so" |
| 110 | |
| 111 | RDEPENDS_${PN} += "perl" |
| 112 | |
| 113 | # valgrind needs debug information for ld.so at runtime in order to |
| 114 | # redirect functions like strlen. |
| 115 | RRECOMMENDS_${PN} += "${TCLIBC}-dbg" |
| 116 | |
Brad Bishop | a34c030 | 2019-09-23 22:34:48 -0400 | [diff] [blame] | 117 | RDEPENDS_${PN}-ptest += " bash coreutils file \ |
| 118 | gdb libgomp \ |
| 119 | perl \ |
| 120 | perl-module-getopt-long perl-module-file-basename perl-module-file-glob \ |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame^] | 121 | procps sed ${PN}-dbg ${PN}-src" |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 122 | RDEPENDS_${PN}-ptest_append_libc-glibc = " glibc-utils" |
| 123 | |
| 124 | # One of the tests contains a bogus interpreter path on purpose. |
| 125 | # Skip file dependency check |
| 126 | SKIP_FILEDEPS_${PN}-ptest = '1' |
| 127 | INSANE_SKIP_${PN}-ptest = "debug-deps" |
| 128 | |
| 129 | do_compile_ptest() { |
| 130 | oe_runmake check |
| 131 | } |
| 132 | |
| 133 | do_install_ptest() { |
| 134 | chmod +x ${B}/tests/vg_regtest |
| 135 | |
| 136 | # The test application binaries are not automatically installed. |
| 137 | # Grab them from the build directory. |
| 138 | # |
| 139 | # The regression tests require scripts and data files that are not |
| 140 | # copied to the build directory. They must be copied from the |
| 141 | # source directory. |
| 142 | saved_dir=$PWD |
| 143 | for parent_dir in ${S} ${B} ; do |
| 144 | cd $parent_dir |
| 145 | |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 146 | subdirs=" \ |
Brad Bishop | a34c030 | 2019-09-23 22:34:48 -0400 | [diff] [blame] | 147 | .in_place \ |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 148 | cachegrind/tests \ |
| 149 | callgrind/tests \ |
Brad Bishop | a34c030 | 2019-09-23 22:34:48 -0400 | [diff] [blame] | 150 | dhat/tests \ |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 151 | drd/tests \ |
| 152 | gdbserver_tests \ |
| 153 | helgrind/tests \ |
Brad Bishop | a34c030 | 2019-09-23 22:34:48 -0400 | [diff] [blame] | 154 | lackey/tests \ |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 155 | massif/tests \ |
| 156 | memcheck/tests \ |
| 157 | none/tests \ |
| 158 | tests \ |
Brad Bishop | a34c030 | 2019-09-23 22:34:48 -0400 | [diff] [blame] | 159 | exp-bbv/tests \ |
| 160 | exp-dhat/tests \ |
| 161 | exp-sgcheck/tests \ |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 162 | " |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 163 | # Get the vg test scripts, filters, and expected files |
| 164 | for dir in $subdirs ; do |
| 165 | find $dir | cpio -pvdu ${D}${PTEST_PATH} |
| 166 | done |
| 167 | cd $saved_dir |
| 168 | done |
| 169 | |
Brad Bishop | a34c030 | 2019-09-23 22:34:48 -0400 | [diff] [blame] | 170 | # The scripts reference config.h so add it to the top ptest dir. |
| 171 | cp ${B}/config.h ${D}${PTEST_PATH} |
| 172 | install -D ${WORKDIR}/remove-for-aarch64 ${D}${PTEST_PATH} |
| 173 | |
| 174 | # Add an executable need by none/tests/bigcode |
| 175 | mkdir ${D}${PTEST_PATH}/perf |
| 176 | cp ${B}/perf/bigcode ${D}${PTEST_PATH}/perf |
| 177 | |
| 178 | # Add an executable needed by memcheck/tests/vcpu_bz2 |
| 179 | cp ${B}/perf/bz2 ${D}${PTEST_PATH}/perf |
| 180 | |
| 181 | # Make the ptest dir look like the top level valgrind src dir |
| 182 | # This is checked by the gdbserver_tests/make_local_links script |
| 183 | mkdir ${D}${PTEST_PATH}/coregrind |
| 184 | cp ${B}/coregrind/vgdb ${D}${PTEST_PATH}/coregrind |
| 185 | |
| 186 | # Add an executable needed by massif tests |
| 187 | cp ${B}/massif/ms_print ${D}${PTEST_PATH}/massif/ms_print |
| 188 | |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 189 | find ${D}${PTEST_PATH} \ |
Brad Bishop | a34c030 | 2019-09-23 22:34:48 -0400 | [diff] [blame] | 190 | \( \ |
| 191 | -name "Makefile*" \ |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 192 | -o -name "*.o" \ |
Brad Bishop | a34c030 | 2019-09-23 22:34:48 -0400 | [diff] [blame] | 193 | \) \ |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 194 | -exec rm {} \; |
Brad Bishop | a34c030 | 2019-09-23 22:34:48 -0400 | [diff] [blame] | 195 | |
| 196 | # These files need to be newer so touch them. |
Brad Bishop | 15ae250 | 2019-06-18 21:44:24 -0400 | [diff] [blame] | 197 | touch ${D}${PTEST_PATH}/cachegrind/tests/a.c -r ${D}${PTEST_PATH}/cachegrind/tests/cgout-test |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 198 | |
| 199 | # find *_annotate in ${bindir} for yocto build |
| 200 | sed -i s:\.\./\.\./cachegrind/cg_annotate:${bindir}/cg_annotate: ${D}${PTEST_PATH}/cachegrind/tests/ann1.vgtest |
| 201 | sed -i s:\.\./\.\./cachegrind/cg_annotate:${bindir}/cg_annotate: ${D}${PTEST_PATH}/cachegrind/tests/ann2.vgtest |
| 202 | |
| 203 | sed -i s:\.\./\.\./callgrind/callgrind_annotate:${bindir}/callgrind_annotate: ${D}${PTEST_PATH}/callgrind/tests/ann1.vgtest |
| 204 | sed -i s:\.\./\.\./callgrind/callgrind_annotate:${bindir}/callgrind_annotate: ${D}${PTEST_PATH}/callgrind/tests/ann2.vgtest |
| 205 | |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 206 | # handle multilib |
| 207 | sed -i s:@libdir@:${libdir}:g ${D}${PTEST_PATH}/run-ptest |
Brad Bishop | a34c030 | 2019-09-23 22:34:48 -0400 | [diff] [blame] | 208 | sed -i s:@bindir@:${bindir}:g ${D}${PTEST_PATH}/run-ptest |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame^] | 209 | |
| 210 | # This test fails on the host as well, using both 3.15 and git master (as of Jan 24 2020) |
| 211 | # https://bugs.kde.org/show_bug.cgi?id=402833 |
| 212 | rm ${D}${PTEST_PATH}/memcheck/tests/overlap.vgtest |
| 213 | |
| 214 | # As the binary isn't stripped or debug-splitted, the source file isn't fetched |
| 215 | # via dwarfsrcfiles either, so it needs to be installed manually. |
| 216 | mkdir -p ${D}/usr/src/debug/${PN}/${EXTENDPE}${PV}-${PR}/${BP}/none/tests/ |
| 217 | install ${S}/none/tests/tls.c ${D}/usr/src/debug/${PN}/${EXTENDPE}${PV}-${PR}/${BP}/none/tests/ |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 218 | } |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame^] | 219 | |
| 220 | # avoid stripping some generated binaries otherwise some of the tests will fail |
| 221 | # run-strip-reloc.sh, run-strip-strmerge.sh and so on will fail |
| 222 | INHIBIT_PACKAGE_STRIP_FILES = "\ |
| 223 | ${PKGD}${PTEST_PATH}/none/tests/tls \ |
| 224 | ${PKGD}${PTEST_PATH}/none/tests/tls.so \ |
| 225 | ${PKGD}${PTEST_PATH}/none/tests/tls2.so \ |
| 226 | ${PKGD}${PTEST_PATH}/helgrind/tests/tc09_bad_unlock \ |
| 227 | ${PKGD}${PTEST_PATH}/memcheck/tests/manuel1 \ |
| 228 | ${PKGD}${PTEST_PATH}/drd/tests/pth_detached3 \ |
| 229 | " |