Brad Bishop | 79641f2 | 2019-09-10 07:20:22 -0400 | [diff] [blame] | 1 | SUMMARY = "Network monitoring tools" |
| 2 | DESCRIPTION = "Utilities for the IP protocol, including traceroute6, \ |
| 3 | tracepath, tracepath6, ping, ping6 and arping." |
| 4 | HOMEPAGE = "https://github.com/iputils/iputils" |
| 5 | SECTION = "console/network" |
| 6 | |
| 7 | LICENSE = "BSD & GPLv2+" |
| 8 | |
| 9 | LIC_FILES_CHKSUM = "file://LICENSE;md5=55aa8c9fcad0691cef0ecd420361e390" |
| 10 | |
| 11 | DEPENDS = "gnutls" |
| 12 | |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame^] | 13 | SRC_URI = "git://github.com/iputils/iputils \ |
| 14 | file://0001-ninfod-change-variable-name-to-avoid-colliding-with-.patch \ |
| 15 | file://0001-ninfod-fix-systemd-Documentation-url-error.patch \ |
| 16 | file://0001-rarpd-rdisc-Drop-PrivateUsers.patch \ |
| 17 | " |
Brad Bishop | 79641f2 | 2019-09-10 07:20:22 -0400 | [diff] [blame] | 18 | SRCREV = "13e00847176aa23683d68fce1d17ffb523510946" |
| 19 | |
| 20 | S = "${WORKDIR}/git" |
| 21 | |
| 22 | UPSTREAM_CHECK_GITTAGREGEX = "(?P<pver>s\d+)" |
| 23 | |
Brad Bishop | 1d80a2e | 2019-11-15 16:35:03 -0500 | [diff] [blame] | 24 | # Fixed in 2000-10-10, but the versioning of iputils |
| 25 | # breaks the version order. |
| 26 | CVE_CHECK_WHITELIST += "CVE-2000-1213 CVE-2000-1214" |
| 27 | |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame^] | 28 | PACKAGECONFIG ??= "libcap libgcrypt rarpd \ |
| 29 | ${@bb.utils.contains('DISTRO_FEATURES', 'ipv6', 'ninfod traceroute6', '', d)} \ |
| 30 | ${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)}" |
Brad Bishop | 79641f2 | 2019-09-10 07:20:22 -0400 | [diff] [blame] | 31 | PACKAGECONFIG[libcap] = "-DUSE_CAP=true, -DUSE_CAP=false, libcap" |
| 32 | PACKAGECONFIG[libgcrypt] = "-DUSE_CRYPTO=gcrypt, -DUSE_CRYPTO=none, libgcrypt" |
| 33 | PACKAGECONFIG[libidn] = "-DUSE_IDN=true, -DUSE_IDN=false, libidn2" |
| 34 | PACKAGECONFIG[gettext] = "-DUSE_GETTEXT=true, -DUSE_GETTEXT=false, gettext" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame^] | 35 | PACKAGECONFIG[ninfod] = "-DBUILD_NINFOD=true,-DBUILD_NINFOD=false," |
Brad Bishop | 79641f2 | 2019-09-10 07:20:22 -0400 | [diff] [blame] | 36 | PACKAGECONFIG[rarpd] = "-DBUILD_RARPD=true,-DBUILD_RARPD=false," |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame^] | 37 | PACKAGECONFIG[systemd] = "-Dsystemdunitdir=${systemd_unitdir}/system,,systemd" |
Brad Bishop | 79641f2 | 2019-09-10 07:20:22 -0400 | [diff] [blame] | 38 | PACKAGECONFIG[traceroute6] = "-DBUILD_TRACEROUTE6=true,-DBUILD_TRACEROUTE6=false," |
| 39 | PACKAGECONFIG[docs] = "-DBUILD_HTML_MANS=true -DBUILD_MANS=true,-DBUILD_HTML_MANS=false -DBUILD_MANS=false, libxslt" |
| 40 | |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame^] | 41 | inherit meson systemd update-alternatives |
Brad Bishop | 79641f2 | 2019-09-10 07:20:22 -0400 | [diff] [blame] | 42 | |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame^] | 43 | # Have to disable setcap/suid as its not deterministic |
| 44 | EXTRA_OEMESON += "--prefix=${root_prefix}/ -DNO_SETCAP_OR_SUID=true" |
Brad Bishop | 79641f2 | 2019-09-10 07:20:22 -0400 | [diff] [blame] | 45 | |
| 46 | ALTERNATIVE_PRIORITY = "100" |
| 47 | |
| 48 | ALTERNATIVE_${PN}-ping = "ping" |
| 49 | ALTERNATIVE_LINK_NAME[ping] = "${base_bindir}/ping" |
| 50 | |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame^] | 51 | SPLITPKGS = "${PN}-ping ${PN}-arping ${PN}-tracepath ${PN}-clockdiff ${PN}-tftpd ${PN}-rdisc \ |
| 52 | ${@bb.utils.contains('PACKAGECONFIG', 'rarpd', '${PN}-rarpd', '', d)} \ |
| 53 | ${@bb.utils.contains('DISTRO_FEATURES', 'ipv6', '${PN}-traceroute6 ${PN}-ninfod', '', d)}" |
Brad Bishop | 79641f2 | 2019-09-10 07:20:22 -0400 | [diff] [blame] | 54 | PACKAGES += "${SPLITPKGS}" |
| 55 | |
| 56 | ALLOW_EMPTY_${PN} = "1" |
Brad Bishop | 79641f2 | 2019-09-10 07:20:22 -0400 | [diff] [blame] | 57 | RDEPENDS_${PN} += "${SPLITPKGS}" |
| 58 | |
| 59 | FILES_${PN} = "" |
| 60 | FILES_${PN}-ping = "${base_bindir}/ping.${BPN}" |
| 61 | FILES_${PN}-arping = "${base_bindir}/arping" |
| 62 | FILES_${PN}-tracepath = "${base_bindir}/tracepath" |
| 63 | FILES_${PN}-traceroute6 = "${base_bindir}/traceroute6" |
| 64 | FILES_${PN}-clockdiff = "${base_bindir}/clockdiff" |
| 65 | FILES_${PN}-tftpd = "${base_bindir}/tftpd" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame^] | 66 | FILES_${PN}-rarpd = "${base_sbindir}/rarpd ${systemd_unitdir}/system/rarpd@.service" |
Brad Bishop | 79641f2 | 2019-09-10 07:20:22 -0400 | [diff] [blame] | 67 | FILES_${PN}-rdisc = "${base_sbindir}/rdisc" |
| 68 | FILES_${PN}-ninfod = "${base_sbindir}/ninfod ${sysconfdir}/init.d/ninfod.sh" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame^] | 69 | |
| 70 | SYSTEMD_PACKAGES = "${@bb.utils.contains('DISTRO_FEATURES', 'ipv6', '${PN}-ninfod', '', d)} \ |
| 71 | ${PN}-rdisc" |
| 72 | SYSTEMD_SERVICE_${PN}-ninfod = "ninfod.service" |
| 73 | SYSTEMD_SERVICE_${PN}-rdisc = "rdisc.service" |