Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame^] | 1 | SUMMARY = "libsecret is a library for storing and retrieving passwords and other secrets" |
| 2 | DESCRIPTION = "A GObject-based library for accessing the Secret Service API of \ |
| 3 | the freedesktop.org project, a cross-desktop effort to access passwords, \ |
| 4 | tokens and other types of secrets. libsecret provides a convenient wrapper \ |
| 5 | for these methods so consumers do not have to call the low-level DBus methods." |
| 6 | LICENSE = "LGPLv2.1" |
| 7 | BUGTRACKER = "https://gitlab.gnome.org/GNOME/libsecret/issues" |
| 8 | LIC_FILES_CHKSUM = "file://COPYING;md5=23c2a5e0106b99d75238986559bb5fc6" |
| 9 | |
| 10 | inherit gnomebase gtk-doc vala gobject-introspection manpages |
| 11 | |
| 12 | DEPENDS += "glib-2.0 libgcrypt gettext-native" |
| 13 | |
| 14 | PACKAGECONFIG[manpages] = "--enable-manpages, --disable-manpages, libxslt-native xmlto-native" |
| 15 | |
| 16 | SRC_URI[archive.md5sum] = "d2dd660a8d502099317bc8af9f30302e" |
| 17 | SRC_URI[archive.sha256sum] = "57f73e94ec6263a17a077fb809cf8cf424637a897a7f15b4eec42ce4aef52447" |
| 18 | |
| 19 | # http://errors.yoctoproject.org/Errors/Details/20228/ |
| 20 | ARM_INSTRUCTION_SET_armv4 = "arm" |
| 21 | ARM_INSTRUCTION_SET_armv5 = "arm" |
| 22 | ARM_INSTRUCTION_SET_armv6 = "arm" |
| 23 | |
| 24 | # vapigen.m4 bundled with the tarball does not yet have our cross-compilation fixes |
| 25 | do_configure_prepend() { |
| 26 | rm -f ${S}/build/m4/vapigen.m4 |
| 27 | } |