Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame^] | 1 | SUMMARY = "Provides a way to load and enumerate PKCS#11 modules" |
| 2 | LICENSE = "BSD-3-Clause" |
| 3 | LIC_FILES_CHKSUM = "file://COPYING;md5=02933887f609807fbb57aa4237d14a50" |
| 4 | |
| 5 | inherit meson gettext pkgconfig gtk-doc bash-completion |
| 6 | |
| 7 | DEPENDS = "libtasn1 libtasn1-native libffi" |
| 8 | |
| 9 | DEPENDS_append = "${@' glib-2.0' if d.getVar('GTKDOC_ENABLED') == 'True' else ''}" |
| 10 | |
| 11 | SRC_URI = "git://github.com/p11-glue/p11-kit" |
| 12 | SRCREV = "762cdaa2cd5c5ec09cc844f9a6bdc551c7f6c8ed" |
| 13 | S = "${WORKDIR}/git" |
| 14 | |
| 15 | PACKAGECONFIG ??= "" |
| 16 | PACKAGECONFIG[trust-paths] = "-Dtrust_paths=/etc/ssl/certs/ca-certificates.crt,,,ca-certificates" |
| 17 | |
| 18 | GTKDOC_MESON_OPTION = 'gtk_doc' |
| 19 | |
| 20 | FILES_${PN} += " \ |
| 21 | ${libdir}/p11-kit-proxy.so \ |
| 22 | ${libdir}/pkcs11/*.so \ |
| 23 | ${libdir}/pkcs11/*.la \ |
| 24 | ${systemd_user_unitdir}/*" |
| 25 | |
| 26 | # PN contains p11-kit-proxy.so, a symlink to a loadable module |
| 27 | INSANE_SKIP_${PN} = "dev-so" |
| 28 | |
| 29 | BBCLASSEXTEND = "nativesdk" |