Patrick Williams | ac13d5f | 2023-11-24 18:59:46 -0600 | [diff] [blame] | 1 | SUMMARY = "Backup, restore, import, and export panel layouts" |
| 2 | SECTION = "x11/application" |
| 3 | LICENSE = "GPL-3.0-only" |
| 4 | LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504" |
| 5 | |
| 6 | inherit python3native gettext gtk-icon-cache features_check |
| 7 | |
| 8 | REQUIRED_DISTRO_FEATURES = "x11 gobject-introspection-data" |
| 9 | |
| 10 | DEPENDS += "intltool-native" |
| 11 | |
| 12 | SRC_URI = "http://archive.xfce.org/src/apps/${BPN}/1.0/${BP}.tar.bz2" |
| 13 | SRC_URI[sha256sum] = "6d08354e8c44d4b0370150809c1ed601d09c8b488b68986477260609a78be3f9" |
| 14 | |
| 15 | do_configure() { |
| 16 | # special configure - no autotools... |
| 17 | ./configure --prefix=${prefix} |
| 18 | } |
| 19 | |
| 20 | do_install() { |
| 21 | oe_runmake 'DESTDIR=${D}' install |
| 22 | sed -i 's:${PYTHON}:python3:g' ${D}${bindir}/xfce4-panel-profiles |
| 23 | } |
| 24 | |
| 25 | FILES:${PN} += "${datadir}/metainfo" |
| 26 | |
| 27 | RDEPENDS:${PN} += "python3-pygobject python3-pexpect" |