Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 1 | SUMMARY = "Utilities for managing LZMA compressed files" |
| 2 | HOMEPAGE = "https://tukaani.org/xz/" |
| 3 | DESCRIPTION = "XZ Utils is free general-purpose data compression software with a high compression ratio. XZ Utils were written for POSIX-like systems, but also work on some not-so-POSIX systems. XZ Utils are the successor to LZMA Utils." |
| 4 | SECTION = "base" |
| 5 | |
| 6 | # The source includes bits of PD, GPL-2.0, GPL-3.0, LGPL-2.1-or-later, but the |
| 7 | # only file which is GPL-3.0 is an m4 macro which isn't shipped in any of our |
| 8 | # packages, and the LGPL bits are under lib/, which appears to be used for |
| 9 | # libgnu, which appears to be used for DOS builds. So we're left with |
| 10 | # GPL-2.0-or-later and PD. |
| 11 | LICENSE = "GPL-2.0-or-later & GPL-3.0-with-autoconf-exception & LGPL-2.1-or-later & PD" |
| 12 | LICENSE:${PN} = "GPL-2.0-or-later" |
| 13 | LICENSE:${PN}-dev = "GPL-2.0-or-later" |
| 14 | LICENSE:${PN}-staticdev = "GPL-2.0-or-later" |
| 15 | LICENSE:${PN}-doc = "GPL-2.0-or-later" |
| 16 | LICENSE:${PN}-dbg = "GPL-2.0-or-later" |
| 17 | LICENSE:${PN}-locale = "GPL-2.0-or-later" |
| 18 | LICENSE:liblzma = "PD" |
| 19 | |
Patrick Williams | 73bd93f | 2024-02-20 08:07:48 -0600 | [diff] [blame] | 20 | LIC_FILES_CHKSUM = "file://COPYING;md5=d4378ea9d5d1fc9ab0ae10d7948827d9 \ |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 21 | file://COPYING.GPLv2;md5=b234ee4d69f5fce4486a80fdaf4a4263 \ |
Patrick Williams | 8e7b46e | 2023-05-01 14:19:06 -0500 | [diff] [blame] | 22 | file://COPYING.GPLv3;md5=1ebbd3e34237af26da5dc08a4e440464 \ |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 23 | file://COPYING.LGPLv2.1;md5=4fbd65380cdd255951079008b364516c \ |
| 24 | file://lib/getopt.c;endline=23;md5=2069b0ee710572c03bb3114e4532cd84 \ |
| 25 | " |
| 26 | |
Patrick Williams | 73bd93f | 2024-02-20 08:07:48 -0600 | [diff] [blame] | 27 | SRC_URI = "https://github.com/tukaani-project/xz/releases/download/v${PV}/xz-${PV}.tar.gz \ |
| 28 | file://run-ptest \ |
| 29 | " |
| 30 | SRC_URI[sha256sum] = "aeba3e03bf8140ddedf62a0a367158340520f6b384f75ca6045ccc6c0d43fd5c" |
Patrick Williams | b58112e | 2024-03-07 11:16:36 -0600 | [diff] [blame] | 31 | UPSTREAM_CHECK_REGEX = "releases/tag/v(?P<pver>\d+(\.\d+)+)" |
| 32 | UPSTREAM_CHECK_URI = "https://github.com/tukaani-project/xz/releases/" |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 33 | |
| 34 | CACHED_CONFIGUREVARS += "gl_cv_posix_shell=/bin/sh" |
| 35 | |
Patrick Williams | 73bd93f | 2024-02-20 08:07:48 -0600 | [diff] [blame] | 36 | inherit autotools gettext ptest |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 37 | |
| 38 | PACKAGES =+ "liblzma" |
| 39 | |
| 40 | FILES:liblzma = "${libdir}/liblzma*${SOLIBS}" |
| 41 | |
| 42 | inherit update-alternatives |
| 43 | ALTERNATIVE_PRIORITY = "100" |
| 44 | ALTERNATIVE:${PN} = "xz xzcat unxz \ |
| 45 | lzma lzcat unlzma" |
| 46 | |
| 47 | BBCLASSEXTEND = "native nativesdk" |
Patrick Williams | 73bd93f | 2024-02-20 08:07:48 -0600 | [diff] [blame] | 48 | |
| 49 | RDEPENDS:${PN}-ptest += "bash file" |
| 50 | |
| 51 | do_compile_ptest() { |
| 52 | oe_runmake check TESTS= |
| 53 | } |
| 54 | |
| 55 | do_install_ptest () { |
| 56 | install -d ${D}${PTEST_PATH}/tests |
| 57 | find ${B}/tests/.libs -type f -executable -exec cp {} ${D}${PTEST_PATH}/tests \; |
| 58 | cp ${B}/config.h ${D}${PTEST_PATH} |
| 59 | for i in files xzgrep_expected_output test_files.sh test_scripts.sh test_compress.sh; do |
| 60 | cp -r ${S}/tests/$i ${D}${PTEST_PATH}/tests |
| 61 | done |
| 62 | mkdir -p ${D}${PTEST_PATH}/src/xz |
| 63 | ln -s ${bindir}/xz ${D}${PTEST_PATH}/src/xz/xz |
| 64 | mkdir -p ${D}${PTEST_PATH}/src/xzdec |
| 65 | ln -s ${bindir}/xzdec ${D}${PTEST_PATH}/src/xzdec/xzdec |
| 66 | mkdir -p ${D}${PTEST_PATH}/src/scripts |
| 67 | ln -s ${bindir}/xzdiff ${D}${PTEST_PATH}/src/scripts/xzdiff |
| 68 | ln -s ${bindir}/xzgrep ${D}${PTEST_PATH}/src/scripts/xzgrep |
| 69 | } |