Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 1 | SUMMARY = "GNU Aspell spell-checker" |
Andrew Geissler | 90fd73c | 2021-03-05 15:25:55 -0600 | [diff] [blame] | 2 | |
| 3 | DESCRIPTION = "Spell checker designed to eventually replace Ispell. \ |
| 4 | It can either be used as a library or as an independent spell checker. \ |
| 5 | Its main feature is that it does a superior job of suggesting possible \ |
| 6 | replacements for a misspelled word than just about any other spell \ |
| 7 | checker out there for the English language." |
| 8 | |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 9 | SECTION = "console/utils" |
| 10 | |
Andrew Geissler | 90fd73c | 2021-03-05 15:25:55 -0600 | [diff] [blame] | 11 | HOMEPAGE = "http://aspell.net/" |
| 12 | |
Andrew Geissler | 7e0e3c0 | 2022-02-25 20:34:39 +0000 | [diff] [blame] | 13 | LICENSE = "LGPL-2.0-only | LGPL-2.1-only" |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 14 | LIC_FILES_CHKSUM = "file://COPYING;md5=7fbc338309ac38fefcd64b04bb903e34" |
| 15 | |
Patrick Williams | 169d7bc | 2024-01-05 11:33:25 -0600 | [diff] [blame] | 16 | SRC_URI = "${GNU_MIRROR}/aspell/aspell-${PV}.tar.gz" |
| 17 | SRC_URI[sha256sum] = "d6da12b34d42d457fa604e435ad484a74b2effcd120ff40acd6bb3fb2887d21b" |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 18 | |
| 19 | PACKAGECONFIG ??= "" |
| 20 | PACKAGECONFIG[curses] = "--enable-curses,--disable-curses,ncurses" |
| 21 | |
| 22 | PACKAGES += "libaspell libpspell aspell-utils" |
| 23 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 24 | RDEPENDS:${PN}-utils += "perl" |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 25 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 26 | FILES:libaspell = "${libdir}/libaspell.so.* ${libdir}/aspell*" |
| 27 | FILES:aspell-utils = "${bindir}/word-list-compress ${bindir}/aspell-import ${bindir}/run-with-aspell ${bindir}/pre*" |
| 28 | FILES:${PN} = "${bindir}/aspell" |
| 29 | FILES:libpspell = "${libdir}/libpspell.so.*" |
| 30 | FILES:${PN}-dev += "${bindir}/pspell-config" |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 31 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 32 | ARM_INSTRUCTION_SET:armv4 = "arm" |
| 33 | ARM_INSTRUCTION_SET:armv5 = "arm" |
| 34 | ARM_INSTRUCTION_SET:armv6 = "arm" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 35 | |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 36 | inherit autotools-brokensep gettext texinfo binconfig-disabled |
| 37 | |
| 38 | BINCONFIG = "${bindir}/pspell-config" |