Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 1 | # NOTE: |
| 2 | # You should use perl-module-test-harness instead of this package, |
| 3 | # unless you specifically need a newer version than what is provided |
| 4 | # by perl in oe-core. |
| 5 | |
| 6 | SUMMARY = "Test::Harness - Run Perl standard test scripts with statistics" |
| 7 | DESCRIPTION = "Although, for historical reasons, the Test::Harness \ |
| 8 | distribution takes its name from this module it now exists only to provide \ |
| 9 | TAP::Harness with an interface that is somewhat backwards compatible \ |
| 10 | with Test::Harness 2.xx. If you're writing new code consider using \ |
| 11 | TAP::Harness directly instead. \ |
| 12 | \ |
| 13 | Emulation is provided for runtests and execute_tests but the \ |
| 14 | pluggable 'Straps' interface that previous versions of Test::Harness \ |
| 15 | supported is not reproduced here. Straps is now available as a stand \ |
| 16 | alone module: Test::Harness::Straps. \ |
| 17 | \ |
| 18 | See TAP::Parser, TAP::Harness for the main documentation for this \ |
| 19 | distribution." |
| 20 | |
| 21 | SECTION = "libs" |
| 22 | |
| 23 | HOMEPAGE = "http://testanything.org" |
| 24 | |
Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 25 | LICENSE = "Artistic-1.0 | GPL-1.0-or-later" |
Patrick Williams | 03907ee | 2022-05-01 06:28:52 -0500 | [diff] [blame] | 26 | LIC_FILES_CHKSUM = "file://README;beginline=29;endline=30;md5=d41d8cd98f00b204e9800998ecf8427e" |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 27 | |
| 28 | SRC_URI = "${CPAN_MIRROR}/authors/id/L/LE/LEONT/Test-Harness-${PV}.tar.gz" |
Patrick Williams | 03907ee | 2022-05-01 06:28:52 -0500 | [diff] [blame] | 29 | SRC_URI[sha256sum] = "7eb591ea6b499ece6745ff3e80e60cee669f0037f9ccbc4e4511425f593e5297" |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 30 | |
| 31 | UPSTREAM_CHECK_REGEX = "Test\-Harness\-(?P<pver>(\d+\.\d+))(?!_\d+).tar" |
| 32 | |
| 33 | S = "${WORKDIR}/Test-Harness-${PV}" |
| 34 | |
| 35 | inherit cpan ptest-perl |
| 36 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 37 | RDEPENDS:${PN} += "\ |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 38 | perl-module-benchmark \ |
| 39 | " |
| 40 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 41 | RPROVIDES:${PN} += "libapp-prove-perl \ |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 42 | libapp-prove-state-perl \ |
| 43 | libapp-prove-state-result-perl \ |
| 44 | libapp-prove-state-result-test-perl \ |
| 45 | libtap-base-perl \ |
| 46 | libtap-formatter-base-perl \ |
| 47 | libtap-formatter-color-perl \ |
| 48 | libtap-formatter-console-perl \ |
| 49 | libtap-formatter-console-parallelsession-perl \ |
| 50 | libtap-formatter-console-session-perl \ |
| 51 | libtap-formatter-file-perl \ |
| 52 | libtap-formatter-file-session-perl \ |
| 53 | libtap-formatter-session-perl \ |
| 54 | libtap-harness-perl \ |
| 55 | libtap-harness-env-perl \ |
| 56 | libtap-object-perl \ |
| 57 | libtap-parser-perl \ |
| 58 | libtap-parser-aggregator-perl \ |
| 59 | libtap-parser-grammar-perl \ |
| 60 | libtap-parser-iterator-perl \ |
| 61 | libtap-parser-iterator-array-perl \ |
| 62 | libtap-parser-iterator-process-perl \ |
| 63 | libtap-parser-iterator-stream-perl \ |
| 64 | libtap-parser-iteratorfactory-perl \ |
| 65 | libtap-parser-multiplexer-perl \ |
| 66 | libtap-parser-result-perl \ |
| 67 | libtap-parsser-result-bailout-perl \ |
| 68 | libtap-parser-result-comment-perl \ |
| 69 | libtap-parser-result-plan-perl \ |
| 70 | libtap-parser-result-pragma-perl \ |
| 71 | libtap-parser-result-test-perl \ |
| 72 | libtap-parser-result-unknown-perl \ |
| 73 | libtap-parser-result-version-perl \ |
| 74 | libtap-parser-result-yaml-perl \ |
| 75 | libtap-parser-resultfactory-perl \ |
| 76 | libtap-parser-scheduler-perl \ |
| 77 | libtap-parser-scheduler-job-perl \ |
| 78 | libtap-parser-scheduler-spinner-perl \ |
| 79 | libtap-parser-source-perl \ |
| 80 | libtap-parser-sourcehandler-perl \ |
| 81 | libtap-parser-sourcehandler-executable-perl \ |
| 82 | libtap-parser-sourcehandler-file-perl \ |
| 83 | libtap-parser-sourcehandler-handle-perl \ |
| 84 | libtap-parser-sourcehandler-perl-perl \ |
| 85 | libtap-parser-sourcehandler-rawtap-perl \ |
| 86 | libtap-parser-yamlish-reader-perl \ |
| 87 | libtap-parser-yamlish-writer-perl \ |
| 88 | " |
| 89 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 90 | do_install:prepend() { |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 91 | # these tests are inappropriate on target |
| 92 | rm -rf ${B}/t/000-load.t |
| 93 | rm -rf ${B}/t/state.t |
| 94 | # these tests require "-T" (taint) option on command line |
| 95 | rm -rf ${B}/t/aggregator.t |
| 96 | rm -rf ${B}/t/bailout.t |
| 97 | rm -rf ${B}/t/base.t |
| 98 | rm -rf ${B}/t/callbacks.t |
| 99 | rm -rf ${B}/t/errors.t |
| 100 | rm -rf ${B}/t/nested.t |
| 101 | rm -rf ${B}/t/object.t |
| 102 | rm -rf ${B}/t/premature-bailout.t |
| 103 | rm -rf ${B}/t/results.t |
| 104 | rm -rf ${B}/t/streams.t |
| 105 | rm -rf ${B}/t/yamlish-output.t |
| 106 | rm -rf ${B}/t/compat/version.t |
| 107 | } |
| 108 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 109 | do_install:append() { |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 110 | install -d ${D}/usr/local/bin |
| 111 | # do not clobber perl-misc /usr/bin/prove |
| 112 | install -m 0755 ${B}/bin/prove ${D}/usr/local/bin/ |
| 113 | rm -rf ${D}${bindir}/prove |
| 114 | rm -rf ${D}${bindir} |
| 115 | } |
| 116 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 117 | FILES:${PN} += "/usr/local/bin/prove" |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 118 | |
| 119 | BBCLASSEXTEND = "native" |