Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 1 | SUMMARY = "Download, build, install, upgrade, and uninstall Python packages" |
| 2 | HOMEPAGE = "http://packages.python.org/setuptools" |
| 3 | SECTION = "devel/python" |
| 4 | LICENSE = "PSF" |
| 5 | LIC_FILES_CHKSUM = "file://setup.py;beginline=78;endline=78;md5=8a314270dd7a8dbca741775415f1716e" |
| 6 | |
| 7 | SRCNAME = "setuptools" |
| 8 | DEPENDS += "python3" |
| 9 | DEPENDS_class-native += "python3-native" |
| 10 | |
| 11 | SRC_URI = " \ |
| 12 | http://pypi.python.org/packages/source/s/${SRCNAME}/${SRCNAME}-${PV}.tar.gz \ |
| 13 | " |
| 14 | SRC_URI[md5sum] = "52b4e48939ef311d7204f8fe940764f4" |
| 15 | SRC_URI[sha256sum] = "0994a58df27ea5dc523782a601357a2198b7493dcc99a30d51827a23585b5b1d" |
| 16 | |
| 17 | S = "${WORKDIR}/${SRCNAME}-${PV}" |
| 18 | |
| 19 | inherit distutils3 |
| 20 | |
| 21 | DISTUTILS_INSTALL_ARGS += "--install-lib=${D}${libdir}/${PYTHON_DIR}/site-packages" |
| 22 | |
| 23 | do_install_prepend() { |
| 24 | install -d ${D}/${libdir}/${PYTHON_DIR}/site-packages |
| 25 | } |
| 26 | # |
| 27 | # The installer puts the wrong path in the setuptools.pth file. Correct it. |
| 28 | # |
| 29 | do_install_append() { |
| 30 | rm ${D}${PYTHON_SITEPACKAGES_DIR}/setuptools.pth |
| 31 | mv ${D}${bindir}/easy_install ${D}${bindir}/easy3_install |
| 32 | echo "./${SRCNAME}-${PV}-py${PYTHON_BASEVERSION}.egg" > ${D}${PYTHON_SITEPACKAGES_DIR}/setuptools.pth |
| 33 | } |
| 34 | |
| 35 | RDEPENDS_${PN} = "\ |
| 36 | python3-distutils \ |
| 37 | python3-compression \ |
| 38 | " |
| 39 | RDEPENDS_${PN}_class-target = "\ |
| 40 | python3-ctypes \ |
| 41 | python3-distutils \ |
| 42 | python3-email \ |
| 43 | python3-importlib \ |
| 44 | python3-numbers \ |
| 45 | python3-compression \ |
| 46 | python3-shell \ |
| 47 | python3-subprocess \ |
| 48 | python3-textutils \ |
| 49 | python3-pkgutil \ |
| 50 | python3-threading \ |
| 51 | python3-misc \ |
| 52 | python3-unittest \ |
| 53 | python3-xml \ |
| 54 | " |
| 55 | BBCLASSEXTEND = "native" |