Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 1 | DESCRIPTION = "Video player and streamer - davinci edition" |
| 2 | HOMEPAGE = "http://www.videolan.org" |
| 3 | SECTION = "multimedia" |
| 4 | |
| 5 | LICENSE = "GPL-2.0" |
| 6 | LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263" |
| 7 | |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 8 | DEPENDS = "coreutils-native fribidi libtool libgcrypt libgcrypt-native \ |
Brad Bishop | 26bdd44 | 2019-08-16 17:08:17 -0400 | [diff] [blame] | 9 | dbus libxml2 gnutls \ |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 10 | tremor faad2 ffmpeg flac fluidsynth alsa-lib \ |
| 11 | lua-native lua libidn \ |
| 12 | avahi jpeg xz libmodplug mpeg2dec \ |
| 13 | libmtp libopus orc libsamplerate0 libusb1 schroedinger taglib \ |
| 14 | tiff" |
| 15 | |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 16 | # While this item does not require it, it depends on ffmpeg which does |
| 17 | LICENSE_FLAGS = "commercial" |
| 18 | |
Brad Bishop | 93c3acf | 2019-10-29 09:48:15 -0400 | [diff] [blame] | 19 | SRC_URI = "http://download.videolan.org/pub/videolan/${BPN}/${PV}/${BP}.tar.xz \ |
| 20 | file://0006-make-opencv-configurable.patch \ |
| 21 | file://0007-use-vorbisidec.patch \ |
| 22 | file://0008-fix-luaL-checkint.patch \ |
| 23 | " |
| 24 | SRC_URI[md5sum] = "744442ec0c145453ea1d257914c8072e" |
| 25 | SRC_URI[sha256sum] = "e0149ef4a20a19b9ecd87309c2d27787ee3f47dfd47c6639644bc1f6fd95bdf6" |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 26 | |
Brad Bishop | 8410d61 | 2019-11-25 09:40:59 -0500 | [diff] [blame] | 27 | inherit autotools gettext pkgconfig features_check |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 28 | |
| 29 | ARM_INSTRUCTION_SET = "arm" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 30 | export BUILDCC = "${BUILD_CC}" |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 31 | EXTRA_OECONF = "\ |
| 32 | --enable-run-as-root \ |
Patrick Williams | ddad1a1 | 2017-02-23 20:36:32 -0600 | [diff] [blame] | 33 | --enable-xvideo \ |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 34 | --disable-screen --disable-caca \ |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 35 | --enable-vlm \ |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 36 | --enable-freetype \ |
| 37 | --enable-tremor \ |
| 38 | --enable-v4l2 --disable-aa --disable-faad \ |
| 39 | --enable-dbus \ |
| 40 | --without-contrib \ |
| 41 | --without-kde-solid \ |
| 42 | --enable-realrtsp \ |
| 43 | --disable-libtar \ |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 44 | --enable-avcodec \ |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 45 | ac_cv_path_MOC=${STAGING_BINDIR_NATIVE}${QT_DIR_NAME}/moc \ |
| 46 | ac_cv_path_RCC=${STAGING_BINDIR_NATIVE}${QT_DIR_NAME}/rcc \ |
| 47 | ac_cv_path_UIC=${STAGING_BINDIR_NATIVE}${QT_DIR_NAME}/uic \ |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 48 | " |
| 49 | |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 50 | PACKAGECONFIG ?= " \ |
| 51 | live555 dc1394 dv1394 notify fontconfig freetype dvdread png \ |
| 52 | ${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'x11', '', d)} \ |
| 53 | " |
| 54 | |
| 55 | inherit ${@bb.utils.contains('PACKAGECONFIG', 'qt5', 'qmake5_paths', '', d)} |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 56 | |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 57 | PACKAGECONFIG[mad] = "--enable-mad,--disable-mad,libmad" |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 58 | PACKAGECONFIG[a52] = "--enable-a52,--disable-a52,liba52" |
| 59 | PACKAGECONFIG[jack] = "--enable-jack,--disable-jack,jack" |
Brad Bishop | 0f291cc | 2019-09-01 15:16:57 -0400 | [diff] [blame] | 60 | PACKAGECONFIG[live555] = "--enable-live555 LIVE555_PREFIX=${STAGING_DIR_HOST}${prefix},--disable-live555,live555" |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 61 | PACKAGECONFIG[libass] = "--enable-libass,--disable-libass,libass" |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 62 | PACKAGECONFIG[postproc] = "--enable-postproc,--disable-postproc,libpostproc" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 63 | PACKAGECONFIG[libva] = "--enable-libva,--disable-libva,libva" |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 64 | PACKAGECONFIG[opencv] = "--enable-opencv,--disable-opencv,opencv" |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 65 | PACKAGECONFIG[speex] = "--enable-speex,--disable-speex,speex" |
| 66 | PACKAGECONFIG[gstreamer] = "--enable-gst-decode,--disable-gst-decode,gstreamer1.0 gstreamer1.0-plugins-base gst-plugins-bad" |
| 67 | PACKAGECONFIG[vpx] = "--enable-vpx,--disable-vpx, libvpx" |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 68 | PACKAGECONFIG[qt5] = "--enable-qt,--disable-qt, qtbase-native qtx11extras qtsvg" |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 69 | PACKAGECONFIG[freerdp] = "--enable-freerdp,--disable-freerdp, freerdp" |
| 70 | PACKAGECONFIG[dvbpsi] = "--enable-dvbpsi,--disable-dvbpsi, libdvbpsi" |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 71 | PACKAGECONFIG[samba] = "--enable-smbclient,--disable-smbclient, samba" |
| 72 | PACKAGECONFIG[upnp] = "--enable-upnp,--disable-upnp,libupnp" |
| 73 | PACKAGECONFIG[dvdnav] = "--enable-dvdnav,--disable-dvdnav,libdvdnav libdvdcss" |
| 74 | PACKAGECONFIG[sftp] = "--enable-sftp,--disable-sftp,libssh2" |
| 75 | PACKAGECONFIG[vorbis] = "--enable-vorbis,--disable-vorbis,libvorbis libogg" |
| 76 | PACKAGECONFIG[ogg] = "--enable-ogg,--disable-ogg,libvorbis libogg" |
| 77 | PACKAGECONFIG[dc1394] = "--enable-dc1394,--disable-dc1394,libdc1394" |
| 78 | PACKAGECONFIG[dv1394] = "--enable-dv1394,--disable-dv1394,libraw1394 libavc1394" |
| 79 | PACKAGECONFIG[svg] = "--enable-svg,--disable-svg,librsvg" |
| 80 | PACKAGECONFIG[svgdec] = "--enable-svgdec,--disable-svgdec,librsvg cairo" |
Brad Bishop | 26bdd44 | 2019-08-16 17:08:17 -0400 | [diff] [blame] | 81 | PACKAGECONFIG[notify] = "--enable-notify,--disable-notify, libnotify gtk+3" |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 82 | PACKAGECONFIG[fontconfig] = "--enable-fontconfig,--disable-fontconfig, fontconfig" |
| 83 | PACKAGECONFIG[freetype] = "--enable-freetype,--disable-freetype, freetype" |
| 84 | PACKAGECONFIG[dvdread] = "--enable-dvdread,--disable-dvdread, libdvdread libdvdcss" |
| 85 | PACKAGECONFIG[vnc] = "--enable-vnc,--disable-vnc, libvncserver" |
| 86 | PACKAGECONFIG[x11] = "--with-x --enable-xcb,--without-x --disable-xcb, xcb-util-keysyms libxpm libxinerama" |
| 87 | PACKAGECONFIG[png] = "--enable-png,--disable-png,libpng" |
Brad Bishop | 7f28bc5 | 2017-12-03 23:42:40 -0500 | [diff] [blame] | 88 | PACKAGECONFIG[vdpau] = "--enable-vdpau,--disable-vdpau,libvdpau" |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 89 | |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 90 | do_configure_append() { |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 91 | sed -i -e s:'${top_builddir_slash}libtool':'${top_builddir_slash}'${TARGET_SYS}-libtool:g ${B}/doltlibtool |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 92 | |
| 93 | # moc needs support: precreate build paths |
| 94 | for qtpath in adapters components/epg components/playlist components/sout dialogs managers styles util/buttons; do |
| 95 | mkdir -p "${B}/modules/gui/qt/$qtpath" |
| 96 | done |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 97 | } |
| 98 | |
| 99 | # This recipe packages vlc as a library as well, so qt4 dependencies |
| 100 | # can be avoided when only the library is installed. |
| 101 | PACKAGES =+ "libvlc" |
| 102 | |
| 103 | LEAD_SONAME_libvlc = "libvlc.so.5" |
| 104 | FILES_libvlc = "${libdir}/lib*.so.*" |
| 105 | |
| 106 | FILES_${PN} += "\ |
| 107 | ${bindir}/vlc \ |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 108 | ${libdir}/vlc/vlc/libvlc_vdpau.so \ |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 109 | ${datadir}/applications \ |
| 110 | ${datadir}/vlc/ \ |
| 111 | ${datadir}/icons \ |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 112 | ${datadir}/metainfo/vlc.appdata.xml \ |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 113 | " |
| 114 | |
| 115 | FILES_${PN}-dbg += "\ |
| 116 | ${libdir}/vlc/*/.debug \ |
| 117 | ${libdir}/vlc/plugins/*/.debug \ |
| 118 | " |
| 119 | |
| 120 | FILES_${PN}-staticdev += "\ |
| 121 | ${libdir}/vlc/plugins/*/*.a \ |
| 122 | " |
Brad Bishop | 7f28bc5 | 2017-12-03 23:42:40 -0500 | [diff] [blame] | 123 | |
| 124 | INSANE_SKIP_${PN} = "dev-so" |
| 125 | |