Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 1 | SUMMARY = "mongodb" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 2 | LICENSE = "SSPL-1 & Apache-2.0 & Zlib" |
| 3 | LIC_FILES_CHKSUM = "file://LICENSE-Community.txt;md5=3a865f27f11f43ecbe542d9ea387dcf1 \ |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 4 | file://APACHE-2.0.txt;md5=3b83ef96387f14655fc854ddc3c6bd57" |
| 5 | |
Brad Bishop | 63ae878 | 2019-10-09 09:56:13 -0400 | [diff] [blame] | 6 | DEPENDS = "openssl libpcap zlib boost curl python3 \ |
Brad Bishop | 0a92126 | 2019-09-24 07:40:45 -0400 | [diff] [blame] | 7 | python3-setuptools-native \ |
| 8 | python3-pyyaml-native python3-cheetah-native \ |
| 9 | python3-psutil-native python3-regex-native \ |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 10 | " |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 11 | |
Brad Bishop | 0a92126 | 2019-09-24 07:40:45 -0400 | [diff] [blame] | 12 | inherit scons dos2unix siteinfo python3native |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 13 | |
Brad Bishop | 0a92126 | 2019-09-24 07:40:45 -0400 | [diff] [blame] | 14 | PV = "4.2.0+git${SRCPV}" |
| 15 | #v4.2.0 |
| 16 | SRCREV = "18ce5c9f56a01f2c933a720d64707f3456f81c8b" |
| 17 | SRC_URI = "git://github.com/mongodb/mongo.git;branch=v4.2 \ |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 18 | file://0001-Tell-scons-to-use-build-settings-from-environment-va.patch \ |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 19 | file://0001-Use-long-long-instead-of-int64_t.patch \ |
| 20 | file://0001-Use-__GLIBC__-to-control-use-of-gnu_get_libc_version.patch \ |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 21 | file://0002-Add-a-definition-for-the-macro-__ELF_NATIVE_CLASS.patch \ |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 22 | file://arm64-support.patch \ |
| 23 | file://0001-IntelRDFPMathLib20U1-Check-for-__DEFINED_wchar_t.patch \ |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 24 | file://0001-Support-deprecated-resolver-functions.patch \ |
Brad Bishop | 0a92126 | 2019-09-24 07:40:45 -0400 | [diff] [blame] | 25 | file://0003-Fix-unknown-prefix-env.patch \ |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 26 | " |
| 27 | SRC_URI_append_libc-musl ="\ |
Brad Bishop | 072e238 | 2019-09-25 08:16:16 -0400 | [diff] [blame] | 28 | file://0001-Mark-one-of-strerror_r-implementation-glibc-specific.patch \ |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 29 | file://0002-Fix-default-stack-size-to-256K.patch \ |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 30 | file://0004-wiredtiger-Disable-strtouq-on-musl.patch \ |
| 31 | " |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 32 | |
| 33 | SRC_URI_append_toolchain-clang = "\ |
| 34 | file://0001-asio-Dont-use-experimental-with-clang.patch \ |
| 35 | " |
| 36 | |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 37 | S = "${WORKDIR}/git" |
| 38 | |
Brad Bishop | 779d0ac | 2019-09-27 08:23:48 -0400 | [diff] [blame] | 39 | COMPATIBLE_HOST ?= '(x86_64|powerpc64|aarch64).*-linux' |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 40 | |
Brad Bishop | 63ae878 | 2019-10-09 09:56:13 -0400 | [diff] [blame] | 41 | PACKAGECONFIG ??= "tcmalloc system-pcre" |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 42 | # gperftools compilation fails for arm below v7 because of missing support of |
| 43 | # dmb operation. So we use system-allocator instead of tcmalloc |
| 44 | PACKAGECONFIG_remove_armv6 = "tcmalloc" |
| 45 | PACKAGECONFIG_remove_libc-musl = "tcmalloc" |
| 46 | |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 47 | PACKAGECONFIG[tcmalloc] = "--use-system-tcmalloc,--allocator=system,gperftools," |
Brad Bishop | 26bdd44 | 2019-08-16 17:08:17 -0400 | [diff] [blame] | 48 | PACKAGECONFIG[shell] = ",--js-engine=none,," |
Brad Bishop | 63ae878 | 2019-10-09 09:56:13 -0400 | [diff] [blame] | 49 | PACKAGECONFIG[system-pcre] = "--use-system-pcre,,libpcre," |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 50 | |
| 51 | EXTRA_OESCONS = "--prefix=${D}${prefix} \ |
| 52 | LIBPATH=${STAGING_LIBDIR} \ |
| 53 | LINKFLAGS='${LDFLAGS}' \ |
| 54 | CXXFLAGS='${CXXFLAGS}' \ |
| 55 | TARGET_ARCH=${TARGET_ARCH} \ |
| 56 | --ssl \ |
| 57 | --disable-warnings-as-errors \ |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 58 | --use-system-zlib \ |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 59 | --nostrip \ |
| 60 | --endian=${@oe.utils.conditional('SITEINFO_ENDIANNESS', 'le', 'little', 'big', d)} \ |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 61 | --wiredtiger=${@['off','on'][d.getVar('SITEINFO_BITS') != '32']} \ |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 62 | ${PACKAGECONFIG_CONFARGS} \ |
Brad Bishop | 26bdd44 | 2019-08-16 17:08:17 -0400 | [diff] [blame] | 63 | core" |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 64 | |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 65 | scons_do_compile() { |
| 66 | ${STAGING_BINDIR_NATIVE}/scons ${PARALLEL_MAKE} ${EXTRA_OESCONS} || \ |
| 67 | die "scons build execution failed." |
| 68 | } |
| 69 | |
| 70 | scons_do_install() { |
| 71 | ${STAGING_BINDIR_NATIVE}/scons install ${EXTRA_OESCONS}|| \ |
| 72 | die "scons install execution failed." |
| 73 | } |